'Legacy Applications' theme is set to null after logout

I’m currently using Kripton theme for my desktop. Everything is working fine until I restart my pc, then the ‘Legacy Applications’ is set to null. This makes many applications appear in default theme instead of Kripton. I tried to set the theme to Kripton again but it still happens when I turn off the pc.

How can I fix this issue? Thank you.

I don’t know about the “Kripton” theme that you are using
but Gnome has a way of frequently invalidating

meaning: they just don’t work anymore as they used to

users customization efforts
as they progress their software development

It’s probably an incompatible theme by now - needs to be adapted to work as intended again.

as a side note:
this is one of the main reasons I have abandoned Gnome
in favor of Xfce4

the constant changes and making it difficult to customize the look and feel just got too annoying - many years ago - not just now …

The default works just fine - but beware of you wanting to adapt things …
make it more pretty or more suite your needs :wink:

That is going to be a real and constant challenge in the long run.

If the theme is stored in your home folder in .themes you may want to move it to /usr/share/themes.

For what benefit? For what reason?

Why put something into system wide
where it is not going to be monitored by the package management system (pacman / pamac)?

… and not working any better than it was, btw …

Because it was possible that at the point the theme setting is looked at, the home directory isnt available leading to a null setting.

hmm - the theme is set/applied when the user is logged in
into the session
the $HOME directory not being available at that point
does not sound plausible
as the user is … using that very $HOME directory

but I made my point in my first post - the theme might not be working for the current Gnome environment …
and we have not had any feedback since

I have seen strange things from Gnome, imho its the most convoluted linux desktop. In the past I had a similar situation with themes.
As far as placing a theme in /usr/share/themes instead of ~./.themes, it makes little difference. All its doing is adding color. But perhaps /usr/local/share/themes would be a better place.
But getting back to the Kripton theme. Its not incompatible. Otherwise they couldnt load it in the first place, only to loose the setting on reboot.
To make sure I booted into my Gnome partition, updated it, and put Kripton v40 in ~./.themes. Enabled it as the legacy them in Appearance, and rebooted several times. The theme just worked.

As I said, I have abandoned Gnome - quite a long time ago (several years)
for reasons like this.

So I don’t know whether the theme is compatible or whether the issue is because of it.

It was just a guess which I’d probably better had kept to myself.
… since I can’t be of any real help here …

@phandungtri I have a similar problem, but with another theme. Did you find a solution?

I’m facing the same issue, but with Tokyonight-Moon-BL. As suggested, I moved my themes from ~/.themes to /usr/share/themes, but this didn’t fix the issue though.

EDIT: I’ve also tried with Nordic theme, and the same issue happens. I tried setting the theme with

gsettings set org.gnome.desktop.interface gtk-theme Nordic-v40
gsettings set org.gnome.desktop.wm.preferences theme Nordic-v40

but the theme just won’t stick. If I restart gnome-shell with ALT+F2 and typing ‘r’, the same issue occurs. Only themes that actually stay after restarting gnome-shell are the ones that come with Manjaro.

I was having the same issue, but I noticed it was related to an extension called (Legacy (GTK3) Theme Scheme Auto Switcher), once I disabled this extension the issue disappeared.


You are our saviour @T4rtar0


Worked for me too. Thank you!