Ldconfig is empy, not checked

Hi everyone!

so what happened was that my pc frozen while updating with pacman, therefore I accidentally uninstalled the kernel (at that time was 5.4). I was able to re install it using an external USB ISO and so I solved that issue (now running 5.8).
However I noticed that I couldn’t compile any latex files and that led me to realize that there were some packages broken.
I searched in the Arch wiki </bbs.archlinux.org/viewtopic.php?id=203517>
for solutions and tried everything there without being able to solve it:

LANG= pacman -Qkk 2>&1 | grep "^warning: .*: /usr/lib.*Size mismatch" | cut -d: -f2 | xargs pacman -S --noconfirm

I am lost to what the problem actually is and how I can solve it,
The output of

pacman -Qkk

it is here: https://filebin.net/ezkqa9u5ywcqeskg
Any help is much appretiated!, thanks in advance


you can use https://filebin.net/ or https://pastebin.com/
As new user you can’t write a link, but you can write url as code </>
EDIT: link edited in your message

Thank you, I’ll then edit the post to be more legible

not good ! errors

grep -Ev “0 altered files|mismatch” /home/patrick/test/design/test.txt

audit: 155 total files, 5 altered files
blueman: 788 total files, 1 altered file
cups: 874 total files, 4 altered files
dhcpcd: 40 total files, 1 altered file
firefox: 97 total files, 1 altered file
ghc-libs: 1412 total files, 1 altered file
grub: 1345 total files, 1 altered file
gvfs: 324 total files, 1 altered file
java-runtime-common: 21 total files, 2 altered files
jre8-openjdk-headless: 177 total files, 1 altered file
lightdm: 388 total files, 1 altered file
manjaro-firmware: 260 total files, 133 altered files
manjaro-hotfixes: 7 total files, 1 altered file
manjaro-release: 3 total files, 1 altered file
pacman-mirrors: 308 total files, 1 altered file
polkit: 198 total files, 1 altered file
samba: 1725 total files, 1 altered file
shadow: 558 total files, 2 altered files
spirv-tools: no mtree file
steam-manjaro: no mtree file
systemd: 1818 total files, 2 altered files
systemd-sysvcompat: no mtree file
talloc: no mtree file
telegram-desktop: no mtree file
texlive-bin: no mtree file
thunderbird: no mtree file
tumbler: no mtree file
vim: no mtree file
vim-runtime: no mtree file
vlc: 1056 total files, 1 altered file
vulkan-intel: no mtree file
vulkan-radeon: no mtree file
wildmidi: no mtree file
xapian-core: no mtree file
xfce4-notifyd: no mtree file
xterm: no mtree file
zeromq: no mtree file

for mtree, you can view fag in old forum

example for “no mtree file”:

ls -d /var/lib/pacman/local/talloc*
# read directory name
sudo touch /var/lib/pacman/local/talloc-XXXXXXXX/desc
ls -d /var/lib/pacman/local/xapian-core*
sudo touch /var/lib/pacman/local/xapian-core-XXXXXXXX/desc

and update at end

Thank you! I’ll have a look at that post

Hi again!

I followed the steps you detailed, however when I try to update I get the following kind of error:

error: failed to commit transaction (conflicting files)
texlive-bin: /usr/bin/afm2pl exists in filesystem

texlive-bin: /usr/share/man/man5/updmap.cfg.5.gz exists in filesystem
Errors occurred, no packages were upgraded.

so accordingly to this ArchWiki </wiki.archlinux.org/index.php/Pacman#%22Failed_to_commit_transaction_(invalid_or_corrupted_package)%22_error>

I should do this:

pacman -S --overwrite glob package

so for instance I tried:

pacman -S --overwrite /usr/share/man/man5/* texlive-bin

to which I get:

error: target not found: /usr/share/man/man1/7z.1.gz
warning: ‘/usr/share/man/man1/7z.1.gz’ is a file, did you mean -U/–upgrade instead of -S/–sync?

Again, thank you for your time spent already!

reverse, it’s

pacman -S package_name --overwrite "path_you_want"

Thank you @papajoke!
It finally worked,
just in case let me add that I had to go with:

pacman -S package_name --overwrite “*”

to update all packages.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.