Latte panel transparency is gone

Hi all,

It’s been a while since I’ve being here last time (a good sign in my case, Manjaro is working flawless!). But now I have a disturbing issue with my Latte panel. It is set to be transparent if there are no maximised windows (checked: “prefer opaque background…”, “hide background when not needed”, “hide background shadow for maximised windows”, “prefer Plasma background…” ) and it has worked fine so far (1-2 years). But since a system update in mid-February, transparency is gone when I’m at the docking station with two screens, unless I move the panel to other part of the screen (say, bottom). If I do this, it immediately starts to behave as expected (transparent with no maximised screen, dark with maximised screen). The issue happens with my both panels in both screens. Even more strange for me, a lay man, with no docking station (single laptop screen), it always behaves as expected, no transparency issue. I have already duplicated and substituted the original panels, and I have reinstalled Latte, even so no fix. Any hint how can I fix this?


Hi @talestomaz,

Since it’s working on the other computer, this seems to be a configuration issue. You could always backup them, delete them (not the backups) and restore the files one-by-one to see in which file the problem lies.

Another option is to copy the working PCs configuration over to the non-working and seee if the problem persists.

Another option would be to compare the configs from the working and the non-working computer and see if there’s a difference. The diff command might be helpful here.

Hope this is the clue you’re looking for.

Personally, I’d just remove the config and re-configure everything:

  1. Backup all files (always make backups):
mv ~/.config/lattedockrc ~/.config/lattedockrc.backup
mv ~/.config/latte ~/.config/latte.backup
mv ~/.local/share/latte-layouts ~/.local/share/latte-layouts.backup
  1. Re-install latte-dock:
pamac reinstall latte-dock
1 Like

The tricky thing is that it has different behaviours in the same computer. The difference actually occurs when it’s connected to two monitors by means of the docking station.

Anyway, I’ve removed Latte and its configs completely and created news panels as you suggested, but the same behaviour is there. Panels are not transparent when I log in. If I move them to the bottom of the screen (or whatever edge) they become transparent again. Even if I send them back to the top, they correctly do their work (transparent with no max window, dark with max window) until I log out and in. Then the cycle begins again. On the other hand, transparency behaviour works just fine in the same computer if it’s not connected to the two monitors (using the docking station). I hope this is clear now…


It’s clearer now. And honestly? Aside from a configuration thing, I don’t know what it could be. The only thing I can think of that might help, is completely removing everything regarding latte-dock and reinstalling it.

And I’m not sure where all the Latte-dock files would be, so I can’t give examples.



To uninstall latte-dock:

pamac remove latte-dock

Then, to remove all traces of it, you can run:

sudo find / -iname 'latte' -exec rm {} \;


This will prompt you for deletion of every file it finds containing “latte”, so don’t rush it so that you’re sure it’s safe and related to latte dock and not a backup or something.

I had problems in the past - Timeshift is a good rescue plan, so go ahead and just dump the folder ~/.config/latte -> latte.bak and try dragging various timeshift backups (or folders) in to see if that works.

Instead of doing reinstall, I’d vote for purging it and testing out the .git version. If you’re lazy, just install the .git and it’ll remove the original - be careful to always make a separate backup ~/.config/latte => latte-git.bak and if you mix anything, be sure to label your layouts with GIT. If layouts get messed up, it’s often not worth bothering to fix them - delete and do it fresh.

I haven’t needed to do this for over a year now, it’s been behaving very well with two panels, one is semi-transparent and goes opaque when touched, and the other puts my Event Calendar at the top of the screen where I can pin my schedule open.

Also, for ‘purge’ you might think about having an alias purge='yay -Rnsuv' to keep it simple.

Good luck :wink:

  1. Removed .config folder
  2. Uninstalled latte-dock
  3. Installed latte-dock-git
  4. Recreated panels from scratch, no single file from prior installation
  5. Same behaviour

This is then my official reaction about it:

:confused: :confused: :confused:


1 Like

Could it be that something is not loading straightforward in the log in and when I change the position of the panel, this is then loaded? Very, very few times (say, 1 in 50 times) I log in and one of the panels (random) starts transparent as intended to work.

That’s why I thought it was some config.


What you COULD always try, is see if the behavior persists with a new, fresh user. If it does, you know it’s something global, and if not, you can always copy that config to your current user, or change to the new user.

Done. Same behaviour.

To be sure:

  1. Created new user (no “home” folder before)
  2. Created panels from scratch
  3. Selected all options for transparency w/ minimised windows
  4. Panels didn’t become transparent
  5. Changed their position (from top to bottom)
  6. Panels became transparent
  7. Logged out
  8. Logged in
  9. Panels were not transparent anymore
  10. Repeat 5 to 10
1 Like

Then it sound like something global and all I can further recommend is that you:

  1. Completely uninstall Latte Dock:
pamac remove latte-dock
  1. Remove all traces of it everywhere:
sudo find / -iname '*latte*' -exec rm {} \;
  1. Reboot.
  2. Reinstall.
pamac install latte-dock

4.1. Hold fingers, cross heart while reinstalling.
5. Reboot again.
5.1. Hold fingers, cross heart while rebooting.
6. Hope for the best; and
6.1. see if it helped.

I’ll try this. I hope I don’t have any file with “latte” in the name…

that’s why you just have to bee very careful. It’ll ask for confirmation for every file, sso you should be safe. Theoretically.

When I use this command, I get a “quote>” and it stops there. I don’t know what to do from now on…

Sincerest apologies. It was a typing error by me that proof-reading missed. It’s fixed now.
Ctrl+C to exit that line, copy and paste the new one ant just run it then.

Thanks, command worked (though it didn’t ask me for any file :grimacing:).

But unfortunately it didn’t solve the problem. When I created a panel, set transparecy, logged out and in again, transparency was gone - unless I change once the panel’s position, then it starts to behave as expected.

I think I sadly give up…

Then I’m completely out of ideas, except creating, testing and perhaps migrating to a new user.

1 Like

Well, now there is a new development - even scarier lol.

I’ve just updated my Manjaro system, and – additionaly to the wrong behaviour described above – now Latte panels do not appear in other virtual desktops apart from Desktop 1 (I work with 4) unless I do the same I’ve been doing to restore transparency, i.e. moving them to the bottom then back to the top. This done, everything runs as usual/intended: both panels in all virtual desktops, all transparent when no window touching, all opaque when touching any window.

[Added: this problem again only occurs when using multiple monitors via docking station. Single laptop monitor has always the expected behaviour.]

It seems to me that somehow Manjaro is not being able to automatically load everything needed for Latte panels during login. Or should I rule out this hypothesis??

I’m completely out of ideas.

Except, perhaps, if you can write a udev rule to automatically perform the actions if the dock is detected. No, I’ve never done this, so have no experience with it and highly doubt I can help you there. But it seems like it might do the job. Because, according to this page:

Udev is the Linux subsystem that supplies your computer with device events. In plain English, that means it’s the code that detects when you have things plugged into your computer, like a network card, external hard drives (including USB thumb drives), mouses, keyboards, joysticks and gamepads, DVD-ROM drives, and so on. That makes it a potentially useful utility, and it’s well-enough exposed that a standard user can manually script it to do things like performing certain tasks when a certain hard drive is plugged in.

Other than that, :man_shrugging:

Just install latte-dock-git from AUR.

Sometimes after the update you need to rebuild the app so it would work correctly. I assume, that the version from repo is obsolete and needs to be rebuild. To not wait for someone, you can install the git version.