Latest update cant install aka clap-host issue

Hello i tried to do the latest December update and before that can even begin i ran into a dependency issue where clap-host has two repos it can install from and they are “Qtractor” and “Reaper” the default being Qtractor.

I selected the default aka Qtractor and then a dependency error showed…

installing DB 6.2.32-1 breaks dependency of DB=5.3.28 required by lib32-db

I get that same error if i pick the Reaper repo as well so how do i get around this so i can update and what is clap-host anyway?

Thanks for your time…

User-added repositories are not officially supported.

Why not use the package from AUR?
It is no more officially supported either, but at least it is a more common source…

Since it’s not in the main repositories, and you don’t seem to use it, you could remove it…

As far as i can tell Qtractor and Reaper are both in the community repos… I don’t use either one so they are not installed.

Also there is no clap-host installed to uninstall it looks to me like its about to be installed in the Dec update and that is causing an issue with the DB versions…

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

You mean clap-host has two packages that provide it. :wink:

Problem solved.


Yes this can be closed now this post thanks for the help…

I uninstalled zam–plugins that was the issue as far as clap-host goes however trying to update after that got rid of the clap-host and the Qtracktor and Reaper showing up by removing zam-plugins however the DB version issue still remained after some more hunting i found a post on that and like the post said i removed the lib32-db and then after that i was able to do a full update and so the machine has booted and everything so far seems to work, audio is fine as well and so the removal of the zam-plugins hasn’t effected anything i can see yet youtube , VLC still have audio… Note if you use pulseeffects the removal of zam-plugins maybe an issue but i’m not sure on that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.