Latest Stable update with Kernel 5.10 breaks Bluetooth (also testing)

Posted this in the stable update post:


Yes, same issue for me, also on plasma

Have you tried other kernels?

This has been an ongoing issue since Kernel 5.9, I am using Fedora 33 and tried the first 5.9.x Kernel and it was boinked. Tried newer ones including 5.10 and it’s still broken. Same issue as yours, “No Adapter Found.” It’s a known issue with the Realtek Wireless/BT module.

1 Like

5.9 and previous versions work

@gperius, then stay on these working kernels until it’s fixed with 5.10.

1 Like

Running on 5.10 with KDE i don’t have any problems. Did you check for an adapter specific driver that might have to be added with 5.10?

Many users are having the issue with all 5.9 Kernels and Bluetooth and Realtek WiFi/BT combo adapter. Guess you’ll have to Google Kernel 5.9 and Bluetooth since I can’t post links.

You may try again with kernels from version 5.10.7-3 onwards, there is a regression-patch included now.

1 Like

Thanks everyone. I’m sticking around with 5.4 LTS until 5.10 says “Recommended” and “LTS” in the Kernels manager. 5.4 is rock solid for me, and I’m a simple man, so I can wait. =)

By the way, turns out kernel update issues aren’t just a scary rolling release / Manjaro issue. Ubuntu has been having some hiccups with the 5.8 driver as part of the HWE stack. Completely broke ALL networking (even ethernet) and bluetooth on one of my systems. So there’s that.

1 Like