Latest stable update broke everything, pacman -Syyuu says there is nothing to do


#1

Latest stable update broke everything. I tried chroot using installation USB and calling pacman -Syyuu, but it says “there is nothing to do”. I also tried changing mirrors using pacman-mirrors, got the same results.

I have no idea what to do. Please help! I need the computer working ASAP! :frowning:

Journalctl -p 3 output screenshotted here:
https://drive.google.com/folderview?id=156I0FbLSl5wKvRXlO0vG-DOoS6OiT_eg


#2

Because I don’t know any better, save your data and reinstall.

Manjaro should put up a sign after the first installation.

Make a security backup, backup, backup …
and read the Announcements before the Backup Update.

https://www.commandlinefu.com/commands/view/6939/remove-all-dead-symbolic-links-in-a-directory

ah, wait, Bogdan is caling :wink:


#3

I rebooted back from the installation USB and suddenly everything works. I don’t know why though. Nothing changed, except for the contents of my /etc/hosts file, where I had a few websites blocked. I really have no idea how it got fixed, but it did.


#4

That’s strange. While you are in the Grub Boot Menu, press e to edit it. On the linux line, replace quiet with 3 and then press F10 to save and continue to boot. It will drop you in TTY. Log in with the root user, enter the password for root, and run:
chown root:root /
systemctl start systemd-tmpfiles-setup
then reboot and hopefully you will be able to boot into your system.

Because there might have been an issue with the systemd-tmpfiles-setup service.
Glad you got your system working! :wink:


#5

Now it is time for backup :smiley: