Latest QGIS update (3.8) is missing/has error with datum transformations

Just upgraded to QGIS 3.8 and opening a brand new empty project, changing the CRS to epgs:27700, gives an error

The preferred transform between EPSG:27700 [OSGB 1936 / British National Grid] and EPSG:4326 [WGS 84] is not available for use on the system.
This transformation requires the grid file “OSTN15_NTv2_OSGBtoETRS.gsb”, which is not available for use on the system. This grid is part of the proj-datumgrid-europe package, available for download from https://download.osgeo.org/proj/proj-datumgrid-europe-latest.zip.
Current transform “Inverse of British National Grid + OSGB 1936 to WGS 84 (6)” has an accuracy of 2 meters, while the preferred transformation “Inverse of British National Grid + OSGB 1936 to WGS 84 (9)” has accuracy 1 meters.

Notwithstanding the fact that the grid file presumably shouldn't be missing, even the current transform (which claims to have an accuracy of 2m) places any 27700 layer in the sea just off South Africa.

The exact same process with 3.6 (on a Manjaro machine not yet upgraded) does not yield this error.

I've raised the issue at QGIS git, but it doesn't seem to be replicable on other systems, so possibly just a Manjaro/Linux version issue.

I just wanted to check in with anyone who uses QGIS (@dobedobedo being the only one I can determine from threads here) . If you've time, could you please open a new blank project, go to Project>Properties>CRS and select 27700, and let me know if the error turns up. Better still, if you have one, load a 27700 layer into a project whose CRS is not 27700 and let me know what happens.

Thanks

Hej Isaacson

You also can try download the file and paste in the file what Qgis use:

  1. download the file than was indicated https://download.osgeo.org/proj/proj-datumgrid-europe-latest.zip

2-Look into the file env.bat of Qgis where you should put the grid

the route is the indicated in the variable

set PRO_LIB=

It is what i did read from internet, from a spanish webpage that i show here (you can use google translate) https://www.cursosgis.com/re-proyeccion-de-capas-empleando-la-rejilla-ntv2/

Good luck.

Haven't check the latest version of QGIS yet. I'm away from my computer now so will check it once I'm back home.

Thanks. I'm going to hold fire on adding the grid manually until I've worked out why it's not there in the first place, but it's good to know it can be done, so I appreciate you tracking that down.

Great, thanks.

Same problem here.
It seems to be a feature! https://www.qgis.org/en/site/forusers/visualchangelog38/index.html#id64

I can confirm that it gives the same error message to me, but it's easy to solve following the method provided by @XtyM:

  1. Click the link in error message to download the missing datum.
  2. Unzip and put everything under /usr/share/proj.

Now everything should work normally.

Still not working for me. I added the files from the zip. I can now change the project CRS to 27700 without the error, I can alos load in 27700 layers without error and select the datum transformation which it previously said it didn't have...so all that's working.

The trouble is, the datum transformation seem to be wrong. With the project CRS set to 27700, 3857 layers don't show up at all. Set the project CRS to 3857, and those layers show up, but the 27700 layers are not transformed at all, they're in the Atlantic off Africa (lat/log 0,0 I think).

Perhaps need to report it on their GitHub.

Hi @Isaacson, I saw the issue is still open on QGIS GitHub. Does a newer version solve the transformation problem?

I haven't had a chance to try it, but the GitHub issue has been closed. It looks like the datum transformations were sometimes given with x/y axis swapped over (god knows why) and Qgis needs them in a consistent order.

I'm not sure what version the fix will be in. Last time I tried to install a version of something not in the repository, it messed up my updates, so I think I will wait this one out.

Forum kindly sponsored by