Latest nvidia driver packages blocked working ones. After update, error message: FAIL Failed to start LightDM Display Manager

Hi everyone,

I’d like to point out that, before updating, you should already have Timeshift set up and have a backup image you can always lean back on. That was a huuuuuge help in this situation, allowing me time to fool around with troubleshooting, but having a great “older” image I could still use for gaming, work, etc.

I’ve been looking for a solution for said problem and many people tried to provide one on this forum. If you’re struggling with an nvidia GPU that literally gets ignored by the new driver (I think I’ve seen it in a boot log somewhere. Lol), here’s what worked for me to go around this issue, while keeping the latest 5.10.79-1 kernel intact. Normally, when you remove the nvidia package, it removes the kernel as well.

(also, experienced mods, if there should be something else on my post, or I should mark it down differently, do let me know, I just wanted to post something about this solution since I’ve been running into this matter for 2 days)

For this to work, you’ll need to know what the running version of the nvidia driver was / is on the older image. Open a terminal, and see it for yourself, on a working version, by typing mhwd -l

The list of steps I’ve done are:

  1. Press Ctrl + Alt + F2 for tty
  2. Log in with your credentials
  3. use this command (in my case, it was video-nvidia-390xx that worked perfectly so far):

sudo mhwd -f -i pci video-nvidia-390xx

This forcefully reinstalls the driver you used before, and its dependencies.

  1. reboot

This worked like a charm for me, after 2 days of info-hunting.
I hope it works for you too!