Latest Manjaro release fails to create ext4 partition

I have an HP Elitebook with a 160GB Intel SSD. I decided to leave 100GB to Windows 10 and install the latest Manjaro KDE image (as of 20 Nov 2020) on the remaining free space (~48GB).
I chose the manual partition install and selected the free space as the destination, but when I attempted to complete the install, I got the following error:

The installer failed to create partition on disk 'INTEL SSDSA1M160G2HP'.
Create a new partition (48.30 GiB, ext4) on ‘/dev/sda’ 
Job: Create new partition on device ‘/dev/sda’ 
Command: sfdisk --force --append /dev/sda 
Failed to add partition ‘New Partition’ to device ‘/dev/sda’. 
Checking that no-one is using this disk right now ... OK 
Disk /dev/sda: 149.05 GiB, 160041885696 bytes, 312581808 sectors 
Disk model: INTEL SSDSA1M160 
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disklabel type: dos 
Disk identifier: 0xf2f4603c 
Old situation: Device Boot Start End Sectors Size Id Type 
/dev/sda1 * 2048 104447 102400 50M 7 HPFS/NTFS/exFAT 
/dev/sda2 104448 210084421 209979974 100.1G 7 HPFS/NTFS/exFAT 
/dev/sda3 210085888 211288063 1202176 587M 27 Hidden NTFS WinRE 
/dev/sda4: No free sectors available. 
Failed to add #4 partition: No space left on device 
Leaving. Failed to add partition ‘New Partition’ to device ‘/dev/sda’. 

I then tried to install Linux Mint on the same free space, and it was successful and created a new ext4 partition in the free space.
I then tried to install Manjaro again, this time using the “Replace partition” option. It failed again with the same “no space left” error.
When I tried the Manjaro install again, using the 20.0.3 image on the free space, it was a success.

Can anyone tell me what might have happened?

You should have created a GPT partition table instead of a dos one…

Several things

You cannot mix MBR and GPT - it is impossible - like fire and water.

MBR (dos) schema only allows four(4) primary partitions and there is no space available to create a partition. My guess is that the 4th partition is defined as an MBR extended partition which is the old way of having more than 4 partitions - an extended partition can hold several smaller partitions - but should be avoided on modern systems.

In any case you need ensure Manjaro is booted from BIOS otherwise Manjaro will boot in EFI mode and you get the above problem. Disable EFI boot in the system firmware.

Thanks for your input. There was a message during the install about GPT, and I can’t remember exactly what it said, but its contents were (I think) somewhat generic, implying that GPT might be the preferred partition scheme. It did not, as I remember it, warn of complications for the installation process, so I chose to ignore it. I must look now at options to convert the whole disk to GPT.

Any idea why the earlier version of Manjaro did complete the same task without issue?

Your input is welcome and appreciated. Even with my decades of personal computer experience, most of it in the Windows world, I’m learning to appreciate Linux much more, and especially Manjaro.
Right or wrong, I’ve had it in my head that GPT was more necessary for large capacity storage devices and not so much for smaller drives like mine. I have almost all of my computers dual-booting now to Windows 10 and Manjaro, but only this one proved a problem. Using GPT might have helped here, but does it explain why the earlier version of Manjaro was successful while the newest version was not?

A post was split to a new topic: My installation hangs forever at creating partition