Latest manjaro kde not running on pc

Using nano, I set OpenGLIsUnsafe=true

On rebooting, the splash screen remained for longer, the welcome to manjaro page appeared, the background screen then went black, and the desktop did not appear.

You need to update your system.
Use TTY or chroot from ISO installer.

If you still have problems, install the non-free nvidia drivers with mhwd.

Hello,

I believe that the non-free nvidia driver is no longer supported by manjaro.

I can update the system.

Regards

Hello,

I wonder if x-org is failing to start for some reason.
Is there anything I can do to ensure that it does start on booting?

Regards

I have updated the system
The system has booted

When I was updating kget-18.08.0-1x86_64 stopped at 68%. I believe that was due to the screen saver cutting in.

I also saw a message: ‘failed to write to cache’ for some files.

However, when it came to updating, kget fully updated.

Is ‘failed to write to cache’ something that I need to do something about?

I also have in .config/kwinrc: OpenGLIsUnsafe now set to true. What does this mean.

Regards

UPDATE.

The system froze during the download of some backup files.
The system became unresponsive, including to REISUB. I had no choice but to switch off the machine.

I am now back where I started with the black screen. I hope to be able to repeat the update

Is it possible that your disks are full for some reason?
Issue this to check (if Xorg is failing, either boot to TTY, or chroot)

df
du -h /var/cache/pacman/pkg

Plenty of room

type or paste code here
[manjaro /]# df
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1       220G  7.7G  202G   4% /
dev             1.9G     0  1.9G   0% /dev
tmpfs           1.9G  3.1M  1.9G   1% /tmp
run             1.9G   70M  1.9G   4% /run
[manjaro /]# du -h /var/cache/pacman/pkg
630M    /var/cache/pacman/pkg
[manjaro /]#


[manjaro /]# du -h /var/cache/pacman/pkg
630M    /var/cache/pacman/pkg
[manjaro /]#

I attempted the re-update, but, evidently, there is nothing to do

It may be Xorg problems or not, I cannot say.
You may try creating another user and login to that to verify it is not a user configuration problem and is system’s.

Side note: Please, edit and format all your posts properly. The code you post is exhausting to read. There is a special format for wrapping terminal output, in the forum post edit toolbar. As a long time user, I was expecting you were already used to this :wink:

Are you sure? As v18.0 series is the latest version we offer. v18.0-b6 just got uploaded today.

The latest stable version

Well, yes, but did you tried the latest development version? It ships with a newer kernel and other things, which might work on your PC the stable version isn’t ?!?

I tried v18,0-b6, but again observed the black screen. I also tried to re-install the current OS from the pendrive, but, for some reason, it will not install beyond 25% (unsquash filesystem).

Did you checksum the ISO you downloaded.

Can you try the XFCE edition just to see if it is some KDE specific issue?

Thank you for responding.

I left the installation running overnight and found that by morning it had installed. Any idea why it should take so long? It don’t think it took that long when initially installed.

I will update the OS, from a terminal, via mhwd-chroot before rebooting and testing the OS.

Previously, when I was downloading my backups from the Net the system froze and would not even respond to REISUB. On switching off the machine and restarting, I ended up with the black screen again.

If something similar happens again, is there a better way to restart?

Regards

Ps, I always check the iso’s against their hashes. So far all iso’s have been found to be original.

I have 4GB of RAM.

Hello,

I had some problems with the hard disk, and have now replaced it

I reinstalled Manjaro (17.1.7. x86-64) and then updated.

When I boot up, I end up with the black screen. But when I type control, Alt, F2 and type startx at the terminal, I then get the desktop. I should be able to avoid this stage.

I also find that after a period the screen becomes black and I am told that the screen locker is broken. I then need to type control, Alt, F1 and login ctl unlock-session c3, then type control, Alt, F2 to get the desktop back

I switched off in Power Management - the screen energy saver, so I am surprised that get the black screen and the message. This problem reoccurs.

Can you advise?

Thanks

UPDATE.

I have now found the button that controls the Lock Screen and have unchecked it.

I think that startx should be put in Autostart, but the menus do not include this programme!

I have just checked my home folder and note that .xinirc is present. Should this file not start the gui automatically?

Always try with the XFCE edition to see if Manjaro works on your end.

Other than having to use startx. Manjaro (kde) is working very well. I will bear in mind XFCE when I get another pendrive.

Best wishes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by