Last upgrade caused Bluefish not to start any more

I use Bluefish for my web programming and since the latest upgrade (yay -Syyu) it won’t start any more. At the console I get the following:

bluefish: error while loading shared libraries: cannot open shared object file: No such file or directory

As far as I know, Bluefish isn’t programmed in Python but in C, which would make this even more peculiar.

I then tried to install libpython, which ended with this error:

ERROR Backend subprocess exited when trying to invoke get_requires_for_build_wheel
==> FEHLER: an error occured in build().
 -> error when building: python-find_libpython-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
python-find_libpython - exit status 4

What kind of manual intervention would be required? Or am I on the wrong path anyway?

I don’t know where is exactly the problem, but it seems to me that it is something you did. The library mentioned in the error ( is part of basic python package that you should have installed.

Your profile says you use stable branch, but have you, for any reason, installed python 3.11, that it is now in testing and unstable branches?

Oh, sorry, I’ll change the profile, I went to testing a few weeks (or months) ago. That’s the reason for 3.11, I guess.

Can you confirm what package version of Bluefish are you using?

pacman -Q bluefish

bluefish 2.2.13-2

That seems to be the last version on testing. That’s a bit odd. This package comes directly from Arch, but if you have it properly installed, it seems to depend on old Python and it needs a rebuild.

You can try to reinstall it, just in case.

I did, no change. The reinstallation went without errors.

Agree with @cfinnberg.

Bluefish from Manjaro Packages website.

Changes at Archlinux website.

What does pacman-mirrors --get-branch show…

Did you reboot the system after update?

What is the output of the following command in your system?

ldd /usr/lib/bluefish/ | grep "python"

I just checked the package on testing and it properly depends on Python 3.11

testing => /usr/lib/ (0x00007f30fe425000)

And yes, I did reboot the system after the upgrade.

Do you have another bluefish somewhere?

type -p bluefish

And also, try to execute it from terminal:


I have a test machine, and changed the branch to testing, updated, and tried bluefish. Other than the usual deprecated theme components, it ran.

Does a sudo pacman -Syyu show any messages or updates?

I did the test of installing the Bluefish Testing version in my Stable system and it starts fine. Bluefish executable doesn’t depend on Python directly, it seems to be only that “zencoding” library. I suspect that the user has some plugin or personalization that triggers this library use at program boot time.

I also confirm an issue with the latest. I am running Manjaro KDE on a Raspberry Pi. I use Bluefish daily, just ran updates, and Bluefish no longer works.
Version is 2.2.13-1

I just did a downgrade to the prior bluefish while the community figures this out. It works now on 2.2.12-3

To run the downgrade (better than messing with a bunch of things for me), I first checked my pacman cache:

ls -l /var/cache/pacman/pkg/bluefish*
-rw-r–r-- 1 root root 2860604 Dec 11 2020 /var/cache/pacman/pkg/bluefish-2.2.12-2-aarch64.pkg.tar.xz
-rw-r–r-- 1 root root 2860176 Dec 31 2021 /var/cache/pacman/pkg/bluefish-2.2.12-3-aarch64.pkg.tar.xz
-rw-r–r-- 1 root root 566 Dec 31 2021 /var/cache/pacman/pkg/bluefish-2.2.12-3-aarch64.pkg.tar.xz.sig
-rw-r–r-- 1 root root 2926680 Feb 27 17:13 /var/cache/pacman/pkg/bluefish-2.2.13-1-aarch64.pkg.tar.xz
-rw-r–r-- 1 root root 566 Feb 27 17:13 /var/cache/pacman/pkg/bluefish-2.2.13-1-aarch64.pkg.tar.xz.sig

Then I rolled back to 2.2.12-3 with:
sudo pacman -U /var/cache/pacman/pkg/bluefish-2.2.12-3-aarch64.pkg.tar.xz

That got me up and running again.

The original problem is in OP’s system, so there is no general problem that needs to be solved.

Also the “problem” is with version 2.2.13-2. Version 2.2.13-1 is the one in community repo and should be fine. So that leads me to believe that your problem is different.

What branch are you using?

If you don’t have the same exact error as OP, open your own thread.

The bluefish package in all repo is 2.2.12-3

The python package in stable is 3.10 but bluefish is linked against 3.11 so on stable branch there is likely to be a python inconsistency.

My glasses need cleaning - I have no idea where the -3 came from other than a reader error.

No, it’s not. Stable repo version is 2.2.13-1 and it is linked against python 3.10

"type -p bluefish gives


I executed from terminal, that shows the error which I posted in the first message:

bluefish: error while loading shared libraries: cannot open shared object file: No such file or directory

That’s not the Manjaro package, you have installed some third party Bluefish.

Try to run “Manjaro’s” Bluefish with: