Large downloads, updates, Netflix/YouTube crash my connection

Hi folks, could you please help a noob out? Oh, btw, they crash my my whole LAN (by ‘crash’ I mean it disconnects them from the DSL line for around 5 minutes) inb4 yeah, I reset my router several times, reinstalled the correct driver network-r8168, stopped using my VPN, YouTube adblocker, restarted NetworkManager, tried several fresh reinstalls and consulted my DSL provider who essentially told me to sod off. The weirdest thing is that YouTube works just fine on a different Manjaro user account (downloads and updates still disconnect my whole LAN from the Internet, though.) Big downloads also disconnect my whole LAN when I dual-boot Windows 10 or use Tails live.

I would kindly appreciate any help from anybody. It all started when I downloaded the NordVPN CLI tool on my previous installation (Ubuntu) and it seems Manjaro has ‘inherited’ the issues, but made them even worse as Netflix or YouTube worked just fine on Ubuntu. I’m now using ProtonVPN with no improvement.


P.S.: sorry for the sob story, but long story short, I have a very important assignment due August 31 and I fail my freshman year if I don’t turn it in, i would really really appreciate your help as I am dependent on the Internet for completing it.

If I understand this correctly:

You have several devices connected to your router.

If one of them starts a large download or transfers a decent amount of data then all of the other devices get disconnected from your router few several minutes. This happens when you perform the same action in Windows or in Linux.

If so, this implies that the router itself is dropping the connections or crashing.

Does the router stay attached to your ISP during this situation?
Have you checked the uptime on the router when everything comes back from its 5 minute disconnection to see if the router itself is rebooting?

sorry for not clarifying it in the first place: only my computer has this problem. my phone or other people’s laptops don’t. the router is not rebooting (definitely, considering that the indicator lights would turn off and on again) and it is not connected to the ISP during the 5 (very roughly) minute downtime.

thanks for the reply.

edit, i wasn’t sure if I’m explaining it well enough: only my computer can trigger the disconnection and all the devices lose their internet. but no other device will trigger the problem.

During the (let’s call it 5 minutes) of downtime can you ping google and also ping your routers IP address?

I ask this because I want to determine if the router is simply going into a sulk and refusing to accept any traffic at all, or whether it’s your upstream ISP or DSLAM which is dropping/resetting the connection before we start dicking about with ethernet connection configs.

Is this wireless or wired?
Can you post your interface config so we can check it for anything daft like a stupidly small MTU setting.

I have to leave for around 2 hours, before I do: It’s wired, going through a powerline adapter to the modem/router and I recall using the router interface during the downtime, so I should be able to ping my router. My interface config is set as per the provider recommendations (MTU=1492 bytes, also the router default, I’ll post the whole config later.) I’ll try deliberately crashing my connection and pinging Google later, but since I was not able to access any remote sites, I don’t think it’ll work.

Thanks for all your help.

I use a similar set up here - powerline adaptor to the router - i use a fairly old TPLINK connector (500 Mbit so nothing fancy) and I found that it would occasiohally go to sleep on me. I now force traffic over it all the time with an endlessly running ping to the router which helps quite a lot.

Either way, we’ll get some testing ran when you get back and see if we can narrow whatever the issue is, down.


I don’t know if I’m understanding this as I don’t use powerline adapters. so please give more information on your setup, by giving us this: The new inxi dump thread — Submit system specs and bookmark your post!


  1. Can you run your eth cable straight to the router?
  2. If on campus, they may have quotas set up to prevent students from downloading big files and slowing down the network.
  3. Check your network settings and make sure the adapter does not go to sleep via power settings.
  4. Are you on a desktop or laptop?

Try running your ethernet from the computer, straight to the router and see if you have the same issue. If not, then the issue is with the powerline adapter. If it does the same thing, then the issue may be with the computer itself meaning the network settings both software and the network adapter itself. Here are some results from a DDG query on your issue.

Check to make sure you don’t have both your wireless and Ethernet connection running at the same time. Make sure the router has the latest firmware, as well as the latest drivers for your network card. Last but not least make sure you have enough memory in your system, if not upgrade your memory.

Use your phone in USB tethering mode on your computer until you find a proper solution.