Laptop won't pass from dell logo

I have this issue where after booting into Manjaro it gets stuck at dell’s logo.

To make it work I need to enter into tty and execute command “startx”, then it will load desktop and everything else. When doing this, if I press escape key or a few others, system will freeze immediately (mouse cursor still works) and I have to enter tty again and reboot. In very few cases after booting, it will load desktop fine and it won’t freeze on keypress. Also, tried to disable shortcuts related to escape but still freeze.

I think this problem is because dual gpu, I don’t any drivers installed beside “video-linux” on nvidia 1650 and “video-linux”, “video-modesetting”, “video-vesa” on Intel UHD.

This started to happen after upgrading kernel to 57 and 58.

Branch: Stable
Desktop Environment: GNOME Lysia 20.0.3
CPU: I7 7590
GPU: Intel UHD graphics and Geforce 1650 laptop
GPU Driver: None
Kernel: 58
Laptop: Dell xps157590


I’m guessing you talk about this model

Yep, that one, I tried disabling UHD on bios but don’t have that option :_(

Can you try another kernel, like 5.4 ?

I tried with 5.4 and 5.6. What happen on these kernels is that it freezes too but not after boot, it freezes randomly while I’m using my laptop; so my guess is because it tries to use dedicated GPU and Integrated at same time. Sometimes just freezes and other times I get display errors like flickering or full yellow screen.

I think you need to use the proprietary drivers for that laptop to work properly.
The easiest will be with

I have two questions:

  1. Can be installed from Hardware configuration under Manjaro Settings Manager?
  2. If so, do I need to install driver for both (Nvidia and Intel)?

Sadly, i cannot add images or links to this post, sorry :confused:

Thanks Bogdan.

You can install them from MSM, yes, or trough terminal
sudo mhwd -i pci video-hybrid-intel-nvidia-driver-450x-prime

And this command should suffice.

Is actually running some scripts. AFAIK the iGPU is already installed, just needs that tweak tho, that the script is running. Don’t know the “behind the scene” of it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.