Laptop stopped going to sleep when lid close Clevo NH55

Test 4.19 and and 4.14 anyways. I may be able to get your card working on other kernels. If it's a qca9377 the fix is to simply rename your firmware.

Its not, I have the Intel ax200.

I've run into a little problem, all the guides on switching to an older kernel says that i can choose it during boot up, but my system boots directly to the login screen. How do i get this option?

How to switch kernels:

When you reboot if you do not see the grub boot screen press and hold down the ESC, SHIFT or F8 key. This should show the GRUB boot menu if it doesn't appear. As soon as you see the grub boot screen, press the down arrow. Select the "advanced" menu from the choices and press enter. In the next menu you can select the different kernels you have installed to boot from. Select the regular kernel you wish boot into (not the fallback), and then press enter to complete the kernel change.

Pressing ESC did the trick.

Kernel 4.14 seems to let my laptop go into sleep mode the 5 or so times i tried.
But as suspected, no wifi from bellow kernel 5.2

Kernels that didn't make a difference:
5.3
5.2
4.19

So bit the bullet and bought an Intel Wireless-AC 9260 m.2 card and replaced the AX200 and for some reason sleep now works even on kernel 5.2

I will test it further and leave the thread open, but for now it seems to be working.

2 Likes

Well that is very significant news. Chances are that I could get your AX200 adapter working with kernel 5.2 or 5.3 as well. It is most likely a combination of the Intel firmware and kernel version causing this.

You may be able to correct this by downgrading the linux-firmware package and testing older firmware. Intel network adapters have been experiencing many issues with recent firmware versions.

If this cannot be corrected by changing firmware then I'm pretty confident the suspend issue can be corrected with a systemd suspend service. I have written many services to correct this type of issue. I have many examples of services to correct this issue on this thread:

As my suggestion to switch kernels appears to have resolved your suspend issue I guess you can mark this thread solved now. If you want assistance trying to get your AX200 adapter working properly let me know.

If you wish to use your AX200 adapter in the near future without resorting to workarounds you should really consider filing a kernel bug report.

Thant is very kind of you, but as my new AX200 adapter is the only wifi 6 hardware i have, I'll stick with the AC 9260 for now and wait till the rest of my network gear gets upgraded (it for sure isn't going to be on the ship, that's for sure :sweat_smile: )
Hopefully it will have been sorted out in the meantime.

I will mark it as solve now and will be sure to read through your thread on systemd :slight_smile:

1 Like

So I thought this issue was fixed, but earlier today it suddenly came back.

I haven't modified or installed anything recently. I tried installing the new Manjaro stable release an hour ago, but it didn't help.

I'm leaving to go sailing for 2 months Saturday morning, so it is a bit urgent :weary:


How to install the latest Intel iwlwifi firmware:


To ensure you have the latest iwlwifi firmware issue the following commands:

sudo pacman -S git --needed
sudo git clone https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
cd linux-firmware
sudo cp iwlwifi-* /lib/firmware/

Reboot


The newest iwlwifi firmware is also available for download here:

https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi

Download the firmware to your home directory.

Then copy your specific firmware to /lib/firmware/:

sudo cp ~/iwlwifi-3160-14.ucode /lib/firmware/

Substitute the name and version number of your specific firmware into the above copy command.


If the most recent iwlwifi firmware doesn't help then I would look to test out older firmware as recent iwlwifi firmware versions have been problematic.



How to load an older version of Intel firmware:


Rename your most recent Intel firmware version with a .bak extension.

Renaming the most recent version of firmware will ensure the older version will be loaded on your next boot.

These instructions will need to modified to reflect your own firmware version.

If you have an Intel 9260 adapter and the most recent firmware is:

/lib/firmware/iwlwifi-9260-th-b0-jf-b0-38.ucode

Then to load an older firmware you would issue this command:

sudo mv /lib/firmware/iwlwifi-9260-th-b0-jf-b0-38.ucode /lib/firmware/iwlwifi-9260-th-b0-jf-b0-38.ucode.bak

You would need to substitute your own adapter's most recent firmware into the above command if you are using a different adapter.

You can find the model of your adapter to substitute in the above command by entering this in the terminal:

inxi -n

You can search for and display all installed iwlwifi firmware with the following command:

sudo ls -lh /lib/firmware/ | grep iwl

Alternatively you can downgrade the linux-firmware package that contains all Linux firmware. That is not the preferred approach as that will also downgrade all other working firmware versions.


I tried the first method you described, I also tried installing the newer 5.3.5-1 kernel without luck.

I got this

-rw-r--r--  1 root root  2.6M 10 okt 20:59 iwlwifi-9260-th-b0-jf-b0-33.ucode
-rw-r--r--  1 root root  2.6M 10 okt 20:59 iwlwifi-9260-th-b0-jf-b0-34.ucode
-rw-r--r--  1 root root  2.5M 10 okt 20:59 iwlwifi-9260-th-b0-jf-b0-38.ucode
-rw-r--r--  1 root root  2.5M 10 okt 20:59 iwlwifi-9260-th-b0-jf-b0-41.ucode
-rw-r--r--  1 root root  2.5M 10 okt 20:59 iwlwifi-9260-th-b0-jf-b0-43.ucode
-rw-r--r--  1 root root  1.4M 10 okt 20:59 iwlwifi-9260-th-b0-jf-b0-46.ucode

Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
           IF: wlp8s0 state: up mac: 5c:87:9c:93:a9:d6 

you say that "38" is the newest, but it seems I have a few that are more recent than that?

Also according to KSysGuard, my wifi is pulling down 11-12MiB/s with my laptop standing idle on the desktop, Im pretty sure it didn't do that before.. :thinking:

I didn't say it was the newest. My instructions were saved a while back and obviously there are newer versions out now.

Start by renaming the newest firmware and work your way backwards to the oldest. Reboot after you have renamed the newest version and work your way backwards through all older firmware. Be sure to test each firmware on kernels 4.14, 4.19, 5.2, and 5.3.

This will be a time consuming process, but you never know which combination of kernel and firmware may be the magic combination.

Try this speed test site:

testmy.net

There are also many iwlwifi driver options you can test.

I just finished writing this so you could test some options that may improve your speed. I do not own an iwlwifi based adapter, so I could not fully test this script. However, it is 100% safe as the changes are only of a temporary nature.

The script will temporarily set iwlwifi driver options that may help your connectivity. The options are only temporary and they will be erased on a reboot (so there is no risk in running the command).

The options can be set permanently afterwards if they improve your connectivity.

Run the following command, and then test your speed:

su -c '/usr/bin/env bash -c echo "restarting network"; nmcli networking off; sleep 1; systemctl stop NetworkManager; sleep 1; DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5); sudo ip link set $DEVICE down; echo -e "\n--- unloading network ---\n"; sleep 2; lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod -v; sleep 2; sudo modprobe -vr mac80211; echo -e "\n--- restarting network ---\n"; sleep 5; modprobe -v mac80211; sleep 5; sudo modprobe -v iwlwifi swcrypto=1 11n_disable=8; sleep 2; ip link set $DEVICE up; sleep 2; systemctl start NetworkManager; sleep 2; nmcli networking on; sleep 2; nmcli r wifi off; sleep 2; nmcli r wifi on; echo -e "\n--- command completed ---\n"'

Please post your input, and all output from that command.

 
--- unloading network ---

rmmod mac80211
rmmod libarc4
rmmod cfg80211

--- restarting network ---

insmod /lib/modules/5.3.5-1-MANJARO/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/5.3.5-1-MANJARO/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko.xz swcrypto=1 11n_disable=8

--- command completed ---

It wouldnt reconnect to wifi afterwards, but a reboot fixed it.

I removed the antenna aggregation option in this version.

Run the following command, and then test your speed:

su -c '/usr/bin/env bash -c echo "restarting network"; nmcli networking off; sleep 1; systemctl stop NetworkManager; sleep 1; DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5); sudo ip link set $DEVICE down; echo -e "\n--- unloading network ---\n"; sleep 2; lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod -v; sleep 2; sudo modprobe -vr mac80211; echo -e "\n--- restarting network ---\n"; sleep 5; modprobe -v mac80211; sleep 5; sudo modprobe -v iwlwifi swcrypto=1; sleep 2; ip link set $DEVICE up; sleep 2; systemctl start NetworkManager; sleep 2; nmcli networking on; sleep 2; nmcli r wifi off; sleep 2; nmcli r wifi on; echo -e "\n--- command completed ---\n"'

Edit:

I had a syntax error in both commands (please rerun both).

--- unloading network ---

rmmod mac80211
rmmod libarc4
rmmod cfg80211

--- restarting network ---

insmod /lib/modules/5.3.5-1-MANJARO/kernel/lib/crypto/libarc4.ko.xz 
insmod /lib/modules/5.3.5-1-MANJARO/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/5.3.5-1-MANJARO/kernel/net/mac80211/mac80211.ko.xz 
insmod /lib/modules/5.3.5-1-MANJARO/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko.xz swcrypto=1

--- command completed ---

Wifi got stuck at
"Setting network address"
and prompted after a while
"IP configuration was unavailable"

I have rewritten the script again and simplified it so that hopefully there will be no errors.

Run the following command, and then test your speed:

su -c '/usr/bin/env bash -c echo "restarting network"; nmcli networking off; sleep 2; systemctl stop NetworkManager; sleep 2; DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5); ip link set $DEVICE down; echo -e "\n--- unloading network ---\n"; sleep 2; lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs rmmod; echo -e "\n--- restarting network ---\n"; sleep 5; modprobe -v iwlwifi swcrypto=1; sleep 2; ip link set $DEVICE up; sleep 2; systemctl start NetworkManager; sleep 3; nmcli networking on; sleep 2; nmcli r wifi off; sleep 2; nmcli r wifi on; echo -e "\n--- command completed ---\n"'

I hope this version improves your connection. :smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by