Laptop random suspend issue where it was perfect two days ago

Since I installed Manjaro on my laptop suspend has been perfectly, never an issue. However, within the last two days it will now randomly come to a black screen forcing me to hold the power button to turn it off. I have tried to switch sessions but nothing helps.

I suspect it is a package I have installed but I’m not sure which it could be. None of them seem like they would cause this issue. I have manually disabled hibernation as it never worked for me.

I thought it might be related to smb4k but I have made sure it was not open with a mount. I recently installed opensnitch and cronpete but didn’t think they would cause this.

Any help would be greatly appreciated! Thank you!

Laptop: HP Pavilion - 15-cs3153cl

Desktop: KDE

INXI:

Current Boot

Maybe its worth looking at the last handful of installed packages?

grep -i installed /var/log/pacman.log | tail -n20

(you can check the same with ‘removed’ or ‘upgraded’)

cscs,

Thank you for reply! I went through the log (n40) looking for anything that might cause an issue like this but nothing jumped out at me. Would you take a look?

Thanks for reply!!!