Laptop not recognizing Realtek RTS525A PCI Express Card Reader

I’ve tried looking for any packages or drivers to help me get my SD card reader going but I only found rts5227-dkms package on the repositories. I actually installed it a few weeks ago and it helped, but today when I put in my SD card it didn’t work anymore. I tried reinstalling the package to no avail.

Is anyone else having problems with this card reader? Can anyone help me get this card reader up and running?

Thanks a lot!

Output:

lspci:

03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)

inxi -Fx:

System:
Host: marco-pc Kernel: 4.17.12-1.1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.1.1 Desktop: KDE Plasma 5.13.4 Distro: Manjaro Linux
Machine:
Type: Laptop System: Dell product: Precision 3520 v: N/A
serial:
Mobo: Dell model: 0FXXKW v: A00 serial: UEFI [Legacy]: Dell
v: 1.4.3 date: 05/11/2017
Battery:
ID-1: BAT0 charge: 52.5 Wh condition: 54.0/68.0 Wh (79%)
model: SMP DELL GD1JP65 status: Charging
CPU:
Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP
arch: Skylake rev: 9 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19972
Speed: 900 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 900 2: 900 3: 900
4: 900
Graphics:
Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0
Card-2: NVIDIA GM107GLM [Quadro M620 Mobile] driver: N/A bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
v: 4.5 Mesa 18.1.5 direct render: Yes
Audio:
Card-1: Intel CM238 HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k4.17.12-1.1-MANJARO
Network:
Card-1: Intel Ethernet I219-LM driver: e1000e v: 3.2.6-k port: N/A
bus ID: 00:1f.6
IF: enp0s31f6 state: down mac: d4:81:d7:e2:11:f8
Card-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel bus ID: 02:00
IF: wlp2s0 state: up mac: 00:28:f8:ee:a7:73
Drives:
Local Storage: total: 465.76 GiB used: 51.81 GiB (11.1%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ACF050 size: 465.76 GiB
RAID:
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
bus ID: 00:17.0
Partition:
ID-1: / size: 80.67 GiB used: 51.81 GiB (64.2%) fs: ext4 dev: /dev/sda6
ID-2: swap-1 size: 15.62 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:
System Temperatures: cpu: 44.0 C mobo: 39.0 C sodimm: 39.0 C
Fan Speeds (RPM): cpu: 2279
Info:
Processes: 206 Uptime: 13m Memory: 15.30 GiB used: 1.92 GiB (12.5%)
Init: systemd Compilers: gcc: 8.1.1 clang: 6.0.1 Shell: bash v: 4.4.23
inxi: 3.0.18

Yes Yes must always have the latest kernel
Let’s leave the fun on the side
Use the kernel 4.14.y

Informationen from Linux Kernel Driver DataBase

Realtek PCI-E card reader found in drivers/mfd/Kconfig
The configuration item CONFIG_MFD_RTSX_PCI:

prompt: Realtek PCI-E card reader
type: tristate
depends on: CONFIG_PCI
defined in drivers/mfd/Kconfig
found in Linux kernels: 3.10–3.19, 4.0–4.15
modules built: rtsx_pci

This supports for Realtek PCI-Express card reader including rts5209, rts5227, rts522A, rts5229, rts5249, rts524A, rts525A, rtl8411, etc. 
Realtek card reader supports access to many types of memory cards, such as Memory Stick, Memory Stick Pro, Secure Digital and MultiMediaCard.

    vendor: 10ec ("Realtek Semiconductor Co., Ltd."), device: 525a ("RTS525A PCI Express Card Reader"), class: ff ("Unassigned class")
    lkddb pci 10ec 525a .... .... ff.... : CONFIG_MFD_RTSX_PCI : drivers/mfd/rtsx_pcr.c # in 4.1–4.15
    driver=rtsx_pci
1 Like

Hello,

Maybe this will help you. https://bbs.archlinux.org/viewtopic.php?id=150134

@123rfou809 did you get it working, I have the same problem.

Hey @cormanj , yeah I dropped down to the 4.14 kernel back then and it worked. Try using an older kernel. I haven’t tested it recently but I am on 4.19 now, it’d be interesting to see if it works now.

Having the same issue with Arch.. Both lts (4.19.37) and current kernel (5.0.9) have this issue.

1 Like

Same problem here.
SD-Card reader does not work with SDXC (or >64GB cards?), only a SDHC card is working (32 & 16GB).
I do not have a 64GB+ SDHC card.

lspci

......
3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
.......

lspci -nnk|grep -A2 RTS525A

3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
        Subsystem: Dell RTS525A PCI Express Card Reader [1028:0704]
        Kernel driver in use: rtsx_pci
        Kernel modules: rtsx_pci

dmesg -w (when inserting the SDXC Card)

mmc0: error -110 whilst initialising SD card

How can this be fixed without Kernel downgrade? I can't read my photos on SDXC. :cry:

Please help!

pappl

Could you get from

journalctl -b

some more information from the
Display console outputs "mmc0", and which kernel
use them, etc.

inxi -Fxzc0

Thank you.

We have to see if the driver you are using is already shipped by the kernel and an update introduced a regression. Which kernel series beside linux414 works?

This bug is reported as fixed with Kernel 5.3. :slightly_smiling_face:

Forum kindly sponsored by