Laptop going straight to BIOS every time I boot, after updates

I have Manjaro installed on one of my Laptops. This laptop is not dual booted and only has Manjaro installed. I haven’t done any updates for a couple of months. Two days ago I ran “pacman -Syu”, and restarted the laptop. When I restarted the laptop, the laptop went straight into the BIOS. So I tried restarting the laptop again, and it went to straight to BIOS again; it keeps on doing this every time I try to start it up. I confirmed in BIOS that the boot order is properly configure. I’m not really sure what to do at this point. Any help would be greatly appreciated.

Also, I’m not really sure this could have made a difference, but when I tried running “pacman -Syu” I kept on getting an error that would say something along the lines of “can’t preform update due to lock file in <filepath_to_lockfile>”. I don’t remember the specific location of the lock file. I ended up deleting the lock file and was able to perform the update.

Welcome to the forum! :slight_smile:

Please keep in mind that Manjaro is a curated rolling-release distribution. This means that updates don’t come at a high frequency, because they are more properly tested and then bundled together before being pushed out, and especially so for the Stable branch.

However, this also means that you should keep your system updated, because software advances rapidly over the course of “a couple of months”, and if you don’t keep up with the evolution, then you’re going to hit a wall sooner or later ─ as you just did.

If you cannot or will not update your system whenever updates are pushed out ─ which should be visible by way of the flashing update notifier icon in your system tray, and which is also always announced here on the forum on dedicated threads under the #announcements category ─ then perhaps Manjaro is not the right distribution for you.

Yes, there was a major update to the GRUB bootloader a few months ago, and in many cases, this required a manual reinstallation of GRUB.

Now, you are not providing us with any information about your system, other than that it’s a laptop and that it has only one OS on it. But no information about your partition table, or whether the machine boots in native UEFI mode or in legacy BIOS (CSM) mode. So I’m going to have to be very generic in my instructions for getting your system up and running again, and you will have to adapt these instructions to whatever your situation is.

First, get yourself a recent bootable Manjaro install medium, be it an optical disk or a USB drive. You can get one of the most recent stable .iso images at this location.

Boot up from the medium in live mode and open up a terminal window. In said window, type the command… :arrow_down:

su -

… and enter the live medium’s root password ─ “manjaro”. Next, issue the following command… :arrow_down:

manjaro-chroot -a

If you are presented with a menu/choice, press 1. Next, issue the following commands… :arrow_down:

pacman-mirrors -f 5 && pacman -Syyu
grub-install --recheck --no-rs-codes --modules="part_gpt part_msdos zstd"

It should now be safe to reboot the system. Good luck! :crossed_fingers:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.