Laptop froze, did fsck but keep getting "no such cryptodisk found" when trying to decrypt harddrive?

Hi there!

So I was doing something with one of those encryption applications (think cryptomator/veracrypt) and when I tried to encrypt something my laptop froze. I then force restarted it and I got an error that recommended I run fsck -y <path>, which I ran and everything “worked”. However, after that when I rebooted my laptop and tried to decrypt my drive I’m running into:

error: access deniued
error: no such cryptodisk found
error: disk `cryptouuid/ca.......` not found
Entering rescue mode

and I’m not sure what to do? From looking around, it seems like most people who run into this issue are either:

  1. dualbooting
  2. running into this issue after updating grub

I see Grub: “no such cryptodisk” error every time I reboot wherein OP seems to come to the conclusion that his HD is F-ed, which I’m REALLY hoping is not the case. Can I get some help? I haven’t touched the grub re-install as in that post yet just to make sure I don’t do anything wrong