Laptop doesn't wake up from suspension

I have an Inspiron 15 3525 that doesn’t wake up from suspension. Tried with swap / without swap and using ext4 and XFS.
I’ve tested with the latest ISO (Gnome install and XFCE) available on the website.
When I try to turn it on again, it flashes the system led for “bad CPU”
In order to get the device working again, I have to manually disconnect the battery, or let it run until it runs out of battery.
Disabling suspension would also help!

AMD Ryzen 5 5500U with Radeon Graphics
AMD Lucienne

Any help is appreciated :slight_smile:

inxi -Fazy

Welcome to the forum! :wave:

Sorry, we don’t know what that means.

Please also see How to Post besides the tutorial linked above.

Sorry for not being that clear! I’m not sure what’s happening, if it’s crashing, or simply dying, or shutting down. I’m not sure exactly what’s going on, but I believe the best would be locking up. I will add more information to the description! Thank you :slight_smile:

  Kernel: 6.6.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=beda9a45-df55-42c9-bc81-94dc52be4885 rw quiet splash apparmor=1
    security=apparmor resume=UUID=22de6023-8fdf-4856-a6a4-7de7bdbd033e
  Console: pty pts/3 DM: LightDM v: 1.32.0 Distro: Manjaro base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 15 3525 v: 1.12.0
    serial: <superuser required> Chassis: type: 10 v: 1.12.0
    serial: <superuser required>
  Mobo: Dell model: 03WW1K v: A00 serial: <superuser required> part-nu: 0B9F
    uuid: <superuser required> UEFI: Dell v: 1.12.0 date: 07/07/2023
  ID-1: BAT1 charge: 28.3 Wh (69.4%) condition: 40.8/40.8 Wh (100.0%)
    volts: 11.7 min: 11.2 model: BYD 0x4A,0x32,0x42,0x34,0x00,0x00,0x00
    type: Li-ion serial: <filter> status: discharging
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 566 high: 1397 min/max: 400/4056 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 1397 7: 400 8: 400 9: 400 10: 400 11: 1397 12: 400
    bogomips: 50323
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: Dell driver: amdgpu v: kernel arch: GCN-5
    code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c class-ID: 0300
    temp: 40.0 C
  Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:3 chip-ID: 0c45:6730
    class-ID: 0e02
  Display: x11 server: v: compositor: xfwm4 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu tty: 120x30
  Monitor-1: eDP-1 model: LG Display 0x06d1 built: 2021 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi inactive: gbm,wayland,x11
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 23.3.5-manjaro1.1
    note: console (EGL sourced) renderer: AMD Radeon Graphics (radeonsi renoir
    LLVM 16.0.6 DRM 3.54 6.6.16-2-MANJARO), llvmpipe (LLVM 16.0.6 256 bits)
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Dell
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.16-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Info: services: NetworkManager, sshd, wpa_supplicant
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1:2 chip-ID: 0bda:c829
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.14 TiB used: 39.97 GiB (3.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SM2P41C3 NVMe 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 92212301 temp: 30.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 2F
  ID-1: / raw-size: 229.37 GiB size: 229.26 GiB (99.95%) used: 22.11 GiB (9.6%)
    fs: xfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 308 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 43.0 C mobo: 36.0 C sodimm: SODIMM C gpu: amdgpu
    temp: 41.0 C
  Fan Speeds (rpm): cpu: 0
  Memory: total: 8 GiB note: est. available: 7.12 GiB used: 1.24 GiB (17.4%)
  Processes: 344 Power: uptime: 2m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 2.83 GiB services: upowerd,xfce4-power-manager Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1147 libs: 370 tools: pamac,yay pm: flatpak
    pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: pty pts/3 (SSH) inxi: 3.3.33

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

I have a similar problem, but I just hard-press power button to force shut it, so no need for such extreme measures.

I also have AMD hardware (CPU and GPU).

See my topic:

I made hibernation work, so that’s one thing, but suspend is working half-way, meaning: laptop suspends but doesn’t wake up correctly.

I found a kernel documentation site that shows various methods of debugging this issue. I haven’t found time to do it yet:

Thanks for the reply! In my case, the shutdown doesn’t work :frowning: (I’ve mashed the button several times already) I will take a look on your post, thanks!

You need to press power and hold it (usually 5-15s) until the computer powers down. This is how power button univerally works in laptops. If this is a PC, then there should be a restart button.

From the site I posted, the first things to look on are points:
2) debug methods and how to enable them and
4) actual debugging suspend/hibernate issues

However, I’m not sure if normal users, as we, can fully use this, because it often shows after some steps:

  • Check if this is a regression.
  • If not, check if this is a graphics issue.
  • If not, check if this is a driver specific issue.

However, I am not sure if I can do that, but the article is big, so maybe there are some ways described there.

Also, check if you have the same issue on a test user (a user with default settings). I do, so the issue is deeper. I also have a plan to install Manjaro on USB stick or another partition, to check if after clean install it works or not.

Other than that, the only lead is debugging and looking for clues online. The worst case scenario, the issue is with drivers or kernels, which we cannot fix ourselves.

I’ve accepted my fate, I’m going with disabling the suspension on the DE (XFCE), it works for my purposes, I hope it gets fixed sometime in the near future :slight_smile:

Regardless of solving or not, your comments were greatly appreciated! Thanks mate.

Did you ever try:

systemctl poweroff
systemctl suspend
systemctl hibernate

and examined the system log those actions left behind?

It was not worth the effort, it won’t comeback from suspension easily, I had to open the backlid, disconnect and connect the battery. So not worth the time and effort to read a few logs. I went with disabling suspension / hibernate, not the most optimal as it is something not enabled by default, but it worked for me. Appreciate your comment mate.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.