Laptop doesn't any reaction on lid close

Fresh manjaro Gnome or KDE installation (or any exist linux distribution(I tryed Fedora36,Ubuntu22.04,OpenSuse,Deepin )
No any reaction on lid close, system not locked internal monitor not switch off etc. Nothing happen at all its seems system not detect hardware trigger. Of course its work on WIN

System:
  Kernel: 5.17.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=2d653f51-3015-4fb9-a442-c9c050ebea25 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 42.1 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: TIMI product: RedmiBook Pro 15S v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: TIMI model: TM2019 v: V44E1 serial: <superuser required> UEFI: TIMI
    v: RMACZ5B0P0707 date: 12/17/2021
Battery:
  ID-1: BATT charge: 67.1 Wh (94.1%) condition: 71.3/70.0 Wh (101.9%)
    volts: 15.4 min: 15.4 model: SCUD R15B02W type: Li-ion serial: <filter>
    status: discharging cycles: -1
Memory:
  RAM: total: 14.55 GiB used: 3.17 GiB (21.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2849 high: 3169 min/max: 400/4463 boost: enabled
    scaling: driver: amd-pstate governor: schedutil cores: 1: 3168 2: 3168
    3: 2528 4: 2534 5: 2535 6: 2529 7: 2532 8: 2536 9: 3165 10: 3165 11: 3162
    12: 3166 13: 3169 14: 3166 15: 2532 16: 2532 bogomips: 102241
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Cezanne vendor: Xiaomi driver: amdgpu v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:1638
    class-ID: 0300
  Device-2: Sunplus Innovation XiaoMi USB 2.0 Webcam type: USB
    driver: uvcvideo bus-ID: 1-3:2 chip-ID: 1bcf:2cdd class-ID: 0e02
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: TL156MDMP01-0 built: 2020 res: 3200x2000 dpi: 242
    gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6") ratio: 16:10
    modes: max: 3200x2000 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.6-1-MANJARO)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Xiaomi
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Xiaomi
    driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_sof_amd_renoir pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Xiaomi driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.6-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    driver: rtw89_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000
    bus-ID: 01:00.0 chip-ID: 10ec:8852 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Opticis Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0cb8:c549 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 14.63 GiB (3.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: KBG40ZNV512G KIOXIA size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: AEXA0102 temp: 35.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 14.63 GiB (3.1%) fs: f2fs dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 2d653f51-3015-4fb9-a442-c9c050ebea25
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: 4F5C-CDC7
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Sunplus Innovation XiaoMi USB 2.0 Webcam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 1bcf:2cdd class-ID: 0e02
  Device-2: 1-4:3 info: Opticis Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0cb8:c549 class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Shenzhen Goodix FingerPrint type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 27c6:581a class-ID: ff00
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 379 Uptime: 25m wakeups: 1608 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1194
  lib: 304 flatpak: 0 Shell: Zsh v: 5.8.1 running-in: gnome-terminal
  inxi: 3.3.15

Please run this to prove it:

sudo libinput debug-events

udo libinput debug-events  :heavy_check_mark:  
-event3 DEVICE_ADDED Video Bus seat0 default group1 cap:k
-event1 DEVICE_ADDED Lid Switch seat0 default group2 cap:S
-event0 DEVICE_ADDED Power Button seat0 default group3 cap:k
-event7 DEVICE_ADDED XiaoMi USB 2.0 Webcam: XiaoMi U seat0 default group4 cap:k
-event8 DEVICE_ADDED GXT7863:00 27C6:01E0 Mouse seat0 default group5 cap:p left scroll-nat scroll-button
-event9 DEVICE_ADDED GXT7863:00 27C6:01E0 Touchpad seat0 default group5 cap:pg size 128x83mm tap(dl off) left scroll-nat scroll-2fg-edge click-buttonareas-clickfinger dwt-on
-event2 DEVICE_ADDED AT Translated Set 2 keyboard seat0 default group6 cap:k
-event9 GESTURE_HOLD_BEGIN +0.040s 1
event9 POINTER_MOTION +0.112s 0.93/ -0.36 ( +3.00/ -1.15)
event9 POINTER_MOTION +0.120s 3.24/ -0.75 ( +5.00/ -1.15)
event9 GESTURE_HOLD_END +0.120s 1 cancelled
event9 POINTER_MOTION +0.126s 4.21/ -2.43 ( +6.00/ -3.46)
event9 POINTER_MOTION +0.133s 4.91/ -1.62 ( +7.00/ -2.31)
event9 POINTER_MOTION +0.140s 4.91/ -2.43 ( +7.00/ -3.46)
event9 POINTER_MOTION +0.147s 4.91/ -2.43 ( +7.00/ -3.46)

output never ends

sudo libinput list-devices

Example (choose another device if needed):

sudo libinput debug-events /dev/input/event0

Look for “lid switch” or “SWITCH_TOGGLE” :wink:

If it is not there. then it is a problem with firmware/UEFI.

there is
sudo libinput debug-events /dev/input/event1  TSTP ✘  8s   
-event1 DEVICE_ADDED Lid Switch seat0 default group1 cap:S

and when lid close\up nothing logged

and what a problem can be in the UEFI/Firmware if its work well on WIN :slight_smile: )

To put it simple: There are drivers/modules which use firmware to call the hardware. If the firmware (here the so called UEFI), have special rules/functions, which are not common (not following the specifications) and are made with windows in mind, then linux cannot call them, but windows can because of the windows drivers.

Only solution I can think of is: Switching Kernels or updating the UEFI.

Well, yes, the pre-installed is win system. but I would never have thought that the laptop close sensor could be a problem for Linux. Let’s refer to the fact that the laptop is too fresh. It’s a pity that this can not be solved by changing the settings. although I’m not an expert,but I installed linux on a bunch of laptops, but this is the first time when I have problem with this critical functionality, an unsuccessful purchase for me :roll_eyes:

https://bbs.archlinux.org/viewtopic.php?id=272473
https://askubuntu.com/questions/1238246/laptop-still-on-when-lid-closed

UEFI is up to date with latest firmware from vendor. Ok will wait for the future kernel relises. Thanks

there is not a suspend or hibernate problem it doesn’t even lock the system and switch off built in monitor

System can with any problem to systemctl suspend

Its simple no reaction on hardware trigger

although I may be wrong something is happening, maybe this will help?

and with systemd-inhibit --what=handle-lid-switch sleep 1m

Please post it as text in a code block. No pictures of text please.

  1. The text is not searchable.
  2. Don’t expect that someone will write everything by hand of a picture because the poster is too lazy to use the Copy&Paste function. :clown_face:

there is text version, sorry

[  210.510881] ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000000b855835 (20211217/exresop-557)
[  210.510891] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  210.510897] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  210.510902] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  210.907624] ACPI Error: Needed [Buffer/String/Package], found [Integer] 00000000846aa96b (20211217/exresop-557)
[  210.907634] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  210.907640] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  210.907645] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  212.241085] ACPI: button: The lid device is not compliant to SW_LID.
[  215.740497] ACPI Error: Needed [Buffer/String/Package], found [Integer] 00000000c6f2e8bb (20211217/exresop-557)
[  215.740508] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  215.740514] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  215.740518] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  216.137230] ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000009e94f261 (20211217/exresop-557)
[  216.137240] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  216.137246] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  216.137251] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  220.683600] ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000008a2e475b (20211217/exresop-557)
[  220.683612] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  220.683619] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  220.683625] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  221.084324] ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000005413f315 (20211217/exresop-557)
[  221.084335] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  221.084341] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  221.084346] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  223.863280] audit: type=1131 audit(1652574495.951:137): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-timedated comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  223.887941] audit: type=1334 audit(1652574495.974:138): prog-id=0 op=UNLOAD
[  223.887954] audit: type=1334 audit(1652574495.974:139): prog-id=0 op=UNLOAD
[  223.887957] audit: type=1334 audit(1652574495.974:140): prog-id=0 op=UNLOAD
[  224.977443] ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000008c04a091 (20211217/exresop-557)
[  224.977454] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  224.977460] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  224.977465] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  225.373168] ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000005563a027 (20211217/exresop-557)
[  225.373178] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Index] (20211217/dswexec-431)
[  225.373183] ACPI Error: Aborting method \_SB.ALIB due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)
[  225.373187] ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._Q80 due to previous error (AE_AML_OPERAND_TYPE) (20211217/psparse-529)

Possible that one of these calls are responsible to the lid switch. No idea… If you want to go down to rabbit hole:

pamac install acpica
mkdir /tmp/acpi
cd /tmp/acpi
sudo acpidump > acpidump.bin
acpixtract -a acpidump.bin
iasl -d *.dat

Now you can view the whole code of ACPI Tables of your hardware and search at the *.dsl files.

More here: ACPI Support — The Linux Kernel documentation

1 Like

Unfortunately I’m not very versed in all this :frowning_face:, and what should I do with these files now, but thanks

Read the comment here about this message:

So only way to fix this, is by updating the firmware. Maybe, if you are smart enough, you can fix it by editing the ACPIdump and overwrite it. But well, there no chance that a kernel update would fix a buggy UEFI. I guess Windows has a workaround for this behavior, but still the problem lies on the firmware, not Linux.

1 Like