Laptop and external monitor

Up until latest system update everything worked fine.
Basically in display settings i disable laptop screen and enable external monitor and make it primary. And it was fine.
But now those settings simply dont work. When I unplug the monitor , its all fine, but if i boot it with monitor, all hell breaks loose, i think that plasmashell crashes every single time when monitor is plugged in so I never see the panel just a blank screen where i still can use Task Runner (alt + f2) and run other programs like dolphin or terminal.

I tried all the combinations that i know to fix this , i deleted plasma-org.kde.plasma.desktop-appletsrc and rebooted. I tried both nonfree and free drivers (yes i unfortunately have nvidia gpu + integrated one)

I’ve seen other similar posts on this topic but nothing worked for me.
Am I just trying to do the impossible? Is it just that laptop+external monitor simply doesnt work on Plasma?
Also before the update when everything worked, i didnt even close the lid, i simply just disabled the screen in display settings.

I dont know anymore what is the issue and where to start fixing this. Im contemplating suicide because its all useless if i cant use the big monitor.

heres my inxi :

  Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=bd6dbd13-60b4-4984-9bf0-9fb675020a88 rw quiet 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 
  dm: LightDM 1.30.0, SDDM Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: K53SV v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: K53SV v: 1.0 serial: <filter> BIOS: American Megatrends 
  v: K53SV.324 date: 12/30/2011 
  Info: Dual Core model: Intel Pentium B950 bits: 64 type: MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 2 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 8384 
  Speed: 2095 MHz min/max: 800/2100 MHz Core speeds (MHz): 1: 2095 2: 2095 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0106 
  Device-2: NVIDIA GF108M [GeForce GT 540M] driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:0df4 
  Device-3: Alcor Micro Asus Integrated Webcam type: USB driver: uvcvideo 
  bus ID: 1-1.2:4 chip ID: 058f:a014 
  Display: x11 server: X . Org 1.20.10 compositor: kwin_x11 driver: intel 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: VGA1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") 
  diag: 690mm (27.2") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1) 
  v: 3.3 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0bea 
  Sound Server: ALSA v: k5.4.85-1-MANJARO 
  Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi 
  v: kernel port: e040 bus ID: 03:00.0 chip ID: 8086:008a 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 9000 
  bus ID: 05:00.0 chip ID: 10ec:8168 
  IF: enp5s0 state: down mac: <filter> 
  Local Storage: total: 111.79 GiB used: 33.09 GiB (29.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SHFS37A120G 
  size: 111.79 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: BBF0 
  ID-1: / raw size: 41.91 GiB size: 41 GiB (97.83%) used: 33.09 GiB (80.7%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 954 MiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 
  System Temperatures: cpu: 77.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 182 Uptime: 24m wakeups: 2 Memory: 5.72 GiB 
  used: 2.72 GiB (47.6%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1335 lib: 409 flatpak: 0 Shell: Bash v: 5.1.0 running in: konsole 
  inxi: 3.2.01 

Please just give me any kind of suggestion , any clue or advice or hint .

You lost your Nvidia driver. Have a look here:

Another thread, maybe helpful in your case:

this is what i have :

im not sure whats going on here
its as if both nonfree and free drivers are installed

i simply dont know what should be my next step here, should i delete everything and just install one kind of driver?
i see a lot of mention of 4xx drivers , but as far as i know only 390 supports my gt540m