Kwin-git and kwin are in conflict. Remove kwin? [y/N]

After restoring my Timeshift, running an update I get this message.

:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                              851.6 KiB  1055 KiB/s 00:01 [##########################
:: Starting full system upgrade...
warning: latte-dock-git: local (r4705.e404abde-1) is newer than community (r4166.1dcf799d-1)
resolving dependencies...
looking for conflicting packages...
:: kwin-git and kwin are in conflict. Remove kwin? [y/N]

However, I have kwin 5.20.5-1 installed. I don’t have kwin-git installed… so why is my system reporting this conflict?

This leads to error installing repo packages.

I did sudo rm -f /var/lib/pacman/sync/* and sudo pacman -Syu and got the same message again…

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
also sudo pacman -Syyuu

What’s up?

This is disappointing - I can’t seem to fix this.
I restored a snapshot from 3 days back on a fresh install, how can this error persist?

You have a git package installed (probably latte-dock-git), which pulls in other -git dependencies, like kwin-git.

I had latte-dock-git installed for a long time…
I’ll try rolling latte back to the basic version and try again.

… no change. Latte-dock is now 0.9.11-1 community

Searching now pacman -Q | grep git

trying solaar-git next > solaar

Getting nowhere fast…

❯ pacman -Q | grep git
dcmtk-git 3.6.6.34.g1c7035cc9-1
git 2.30.0-1
kdsoap-ws-discovery-client git20200927-1
kwin-effect-osdclock-git 20210113.7999e93-1
kwin-scripts-krohnkite-git r464.2a47753-2
libgit2 1:1.1.0-1
material-kwin-decoration-git v6+1+g32ccfde-1
mlocate 0.26.git.20170220-5

Certainly it wasn’t OSD clock, or Krohnkite, nor the kwin-decoration.

dcmtk-git is part of Dicon installed last year.

Checking the list like this:

❯ pacman -Qi kdsoap
Name            : kdsoap
Version         : 1.10.0-1
Description     : Qt-based client-side and server-side SOAP component
Architecture    : x86_64
URL             : https://github.com/KDAB/KDSoap
Licenses        : GPL3  LGPL  custom
Groups          : None
Provides        : None
Depends On      : qt5-base
Optional Deps   : None
Required By     : kdsoap-ws-discovery-client
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 1582.49 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 23 Dec 2020 01:43:37 +07
Install Date    : Tue 19 Jan 2021 22:05:02 +07
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

❯ pacman -Qi kdsoap-ws-discovery-client
Name            : kdsoap-ws-discovery-client
Version         : git20200927-1
Description     : WS-Discovery client library based on KDSoap

Required By     : kio-extras
Optional For    : None
Conflicts With  : None
Replaces        : None

Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Nothing about kwin-git.

I’m not happy…
The culprit, an update to 4.1.2 - kwin-effects-yet-another-magic-lamp 4.1.3.r1c9fc49b-1

Now doesn’t work with kwin, needs to completely replace with git - quite a long list.

Hopefully things will be sorted in a week or so.

https://aur.archlinux.org/packages/kwin-effects-yet-another-magic-lamp/

Seems it just requires kwin 5.21. So it will come in time.

I was really in a mess with this one - yesterday I switched to testing, then back to stable, and couldn’t figure out what had happened.

8 hours - a new record.

Thanks for the tip :wink: put me on the right track.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.