Kwin crashes every <1h


inxi -F
System:    Host: pc Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.5 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX B350-F GAMING v: Rev X.0x serial: <superuser required> 
           UEFI: American Megatrends v: 5603 date: 07/28/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP L2 cache: 3 MiB 
           Speed: 1912 MHz min/max: 1550/3600 MHz Core speeds (MHz): 1: 1912 2: 1392 3: 1429 4: 1423 5: 3479 6: 3046 7: 1424 
           8: 1429 9: 2382 10: 1361 11: 1491 12: 3020 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 460.39 
           Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia resolution: 3440x1440~100Hz 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 
Audio:     Device-1: NVIDIA GP104 High Definition Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Device-3: Logitech Webcam C170 type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k5.10.15-1-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network driver: igb 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 88:d7:f6:c7:35:6a 
           Device-2: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB driver: btusb,rtl8xxxu 
           IF: wlp1s0f0u5i2 state: down mac: 82:0b:fc:1c:41:1f 
Bluetooth: Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB driver: btusb,rtl8xxxu 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.14 TiB used: 698.82 GiB (60.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM014-1EJ164 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 69.17 GiB used: 46.58 GiB (67.3%) fs: ext4 dev: /dev/sdb7 
           ID-2: /boot/efi size: 63 MiB used: 270 KiB (0.4%) fs: vfat dev: /dev/sdb6 
           ID-3: /home size: 49.78 GiB used: 30.33 GiB (60.9%) fs: ext4 dev: /dev/sdb5 
Swap:      ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) file: /swapfile 
Sensors:   System Temperatures: cpu: 44.4 C mobo: N/A gpu: nvidia temp: 37 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 365 Uptime: 18m Memory: 15.63 GiB used: 5 GiB (32.0%) Shell: Bash inxi: 3.3.01

From a week or so, I’ve been experiencing an issue with kwin. It always crashes.
After it crashes, i have to go to compositor in settings, re-enable compositor, then via terminal:
kwin_x11 --replace
This fix the issue for some time, less than an hour (some times even few minutes), but then it crashes again.
I can’t see any particular pattern when it crashes. The display freezes for few seconds (but not the system, because I can still hear audio if I was watching a video) and then kwin stops.
Two days ago, I updated kwin, but did not resolve the issue. I switched to kwin-low-latency but the issue is still there.

1 Like

Does this also happen when you create a new user and log in there? (E.G. luigir-it2)

If yes, can you post for the new user the output of:

journalctl --priority=3 --boot=0 | grep --ignore-case kwin


P.S. If that would be too big, take --priority=2.

I’m sorry, I’ve just seen you answer. After updating to plasma 5.21 it didn’t crash anymore

1 Like

Man I do really hate to do a:

DISPLAY=:0 kwin_x11 --replace

at tty2 in every 2 hours in Manjaro!!

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.