kwalletd5, WiFi password, Bluetooth keyboard, smb broken, on KDE - 9.0.2 Manjaro

Need a little advice please...

I keep getting a pop-up message about needing to enter password for this "kwalletd5" on reboot. is this KDE wallet service needed and what does it do?

WiFi not remembering password on reboot.

Bluetooth keyboard has to be reconnected every time on reboot.

smb: not showing any network drives since system update, had one drive mapped in Dolphin but it says: "Connection to host tp-share is broken."

Thanks for any help you can provide,


Secure and unified container for user passwords.

Because you did not set to remember the password for all users, and you did not set to be remembered in kwallet.

Probably because is trying to connect before the wifi is available/connected, hence there is no communication ...

1 Like

Thank you Bog for the fast reply and the help!

Link you sent me on wiki fixed my wallet and WiFi problem!

Still have the smb problem as I can not see any of my network drives on my network.

Also BT keyboard still has to be connected every time I reboot.

Not sure how you configured it. Maybe you have to use smb4k as client ... or maybe you have to use client max protocol = NT1in smb.conf :man_shrugging:

Probably better to pair it via mac address. Detailed instructions you can find here:

1 Like

Thanks again for the fast response bog!

So far things are looking much better with my Kyria!

Perhaps you can point me in the direction for a fix for getting Frostwire to see my share?
As you can see below, Dolphin shows the third folder which is the share on the network but for some reason Frostwire does not see it:

No experience with FrostWire. Sorry :slight_smile:

All good! Most likely someone has run into this issue and will chime in.

Let me through this curve-ball at you:

Date and time is showing the calendar in espanol, and why I don't have a problem reading and speaking espanol as I am bilingual I am not sure why it is doing it?

I am retired in Jardin Colombia SA so I am sure it is picking up my location but I have everything set to English in settings and when I installed the OS I used English.

Settings > Locale > System Locale
and see if there you have the Formats set to Spanish.
Double click on the English and it will set all to it, from this:
to this

Log out and and back in. All should be in English.

1 Like

That fixed it!

Thanks again for all the help!


1 Like

Forum kindly sponsored by