Kuickshow - keyboard shortcuts not working or remembered

Hi All,
I did a search and didn’t see much with respect to Kuickshow.

Here’s the details in short:
I’m running KDE and want to use Kuickshow to run a slideshow of images I have in one particular directory.

So far it works great, it remembers my settings for the images just fine.

The problem is/are as follows.
To start the slideshow the menu says you can press F2, however when I do that I get the following error message:

The key sequence ‘F2’ is ambiguous. Use ‘Configure Keyboard Shortcuts’

from the ‘Settings’ menu to solve the ambiguity.

No action will be triggered.

When I go into the settings, I can program any key to automatically start the slideshow and it works fine, until I close the program and restart it, then it completely forgets the programmed keyboard shortcut, but it still remembers the other settings that I have made (with respect to image display).

I don’t know if this is just a Kuickshow issue or one related to say KDE in general.

Any help that you may provide will be greatly appreciated.

I’d say it’s more generically KDE. Sometimes you have to log out and back in for the setting to stick.

I just tried this and no joy.

Yeah, KDE/Plasma is somewhat unpredictable in that. Sometimes it works, other times it doesn’t. :frowning_man:

Maybe I’ll try posting in the KDE section to see if anyone has faced a similar issue and found a way to resolve it.

EDIT: I just noticed at the top of this thread that it is marked Support and KDE (I never noticed those tags before).
So I won’t be posting in the KDE section. It would not have been a duplicate post, I’m pretty sure those are frowned upon.

If I am wrong and it is worthwhile seeking help in the KDE section, please let me know.

You already have. The sections just filter based on tags, and you’ve already noticed the tags.

That’s not a solution so I unmarked it.

I had noticed in another, unrelated thread, that a mod had marked it Solved even though there wasn’t a solution.
I thought they had done that to simply close out a “dead” thread.
I know better for next time.

Perhaps they did, I’m not a mod, but it’s annoying to find a solved thread without a solution.

It’s only been open for a day, there may yet be a solution.



First off, I have very little experience with kde and I’ve only had a quick look at kuickshow. I dragged out my laptop (a recent convert to kde) and installed kuickshow. I also tested on mate and the behaviour is the same, I didn’t remap any global shortcuts with mate.

By default F2 is used for both “Start Slideshow” and “Rename” which is why it’s ambiguous.

If you change rename in kuickshow it doesn’t change the global shortcut of the same name, however if you change it globally then kuickshow’s binding is also changed. The shortcuts seem to be stored globally, or are a mix of global and local. kuickshow can read them but can’t store them.

So an obvious workaround is to remap the global rename shortcut, then F2 will work in kuickshow.

“System Settings” → “Shortcuts” → “Shortcuts” → Search for rename

There seem to be no open issues, perhaps you should register and open one. They can investigate and figure out where the bug is, and re-evaluate their default keybindings.

They’re not tags. It is the KDE Plasma category, as a subcategory of Support. And I was the one who moved it there because you are addressing a KDE-specific application in a Plasma desktop environment. :wink:

Tags are just additional information intended to be able to search for keywords via the forum’s built-in search function. They’re not categories, and some people tend to abuse them and even add tags of their own making because they think they’ll get help faster that way.

People are selfish.

A solution mark doesn’t have to literally represent what solved the problem. A post can be marked as the solution if it sets you on your way to solving the problem.

Even just about half an hour ago, I had to change over the solution on a thread because somebody had posted the information on how to solve the problem, and the poster then stated that said post was where the answer laid, and marked their own post as the solution.

Also, yes, if a potential solution is given and the original poster never even bothers coming back to the thread, then we consider said potential solution to have been the proper one, and then we close the thread — or at least, marking a solution triggers an auto-close timer — so as to avoid necro-bumping and/or thread hijacking.

1 Like

Thank you for the explanation, I appreciate it.

Good to know, I thought I was losing it, being certain that I had posted in a different section. :sweat_smile:

1 Like

Yes, you had posted it in Software & Applications. :wink:

At the moment, Manjaro does not offer branded straitjackets yet, but if you were to ask @philm nicely, I’m sure he’d be able to arrange something… :crazy_face:

1 Like

ROTFLMAO!!! Not exactly the tailor made suit I was hoping for but I’ll give it a try. :rofl:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.