Krusader Runners Roost

I’ve been using manjaro for about a year now. I have installed krusader file manager and while it was open and in root mode, i went under settings-configure krusader, and under user interface, i checked to box “start to tray”, which i understood to be the icon tray on the bottom right of the screen. Now when i open krusader and then go under root mode, it asks for my root password, but it does not open a new window for root mode. I’ve tried uninstalling and reinstalling krusader with no avail, I have checked out the configuration file to see if I could change it there, and have found nothing, can anybody help me with my problem

Did you check if it did open, but it’s in your tray?

If I open up the program menu, which I can’t think of what the name of it is, I can see it running in the background but I can’t get it to display

Root has nothing to do in X

You didn’t answer my question… did you check your tray?

Yes when I open it as root it appears in the system tray in the lower right corner of the tray but only for a second then it disappeared

Could you explain why root has nothing to do with x

Better said, in X.

I still don’t understand, I can get krusader to open, but when I go to shift it to start and root mode the root mode window won’t open, or I should say it opens but it only runs it in the background from what I see, it does not appear in my system tray and if it does it’s only for just a moment

pacman -S ksshaskpass

Krusaders ActionManager

EDITOR=‘kate -b’ SUDO_ASKPASS=/usr/bin/ksshaskpass sudoedit -A %aCurrent%

thats all

So I’m sure of what I’m doing, but this is what I got in term

chris@chris-pc ~]$ sudo pacman -S ksshaskpass
[sudo] password for chris:
warning: ksshaskpass-5.21.4-1 is up to date – reinstalling
resolving dependencies…
looking for conflicting packages…

Packages (1) ksshaskpass-5.21.4-1

Total Installed Size: 0.09 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [#######################################################################################] 100%
(1/1) checking package integrity [#######################################################################################] 100%
(1/1) loading package files [#######################################################################################] 100%
(1/1) checking for file conflicts [#######################################################################################] 100%
(1/1) checking available disk space [#######################################################################################] 100%
:: Processing package changes…
(1/1) reinstalling ksshaskpass [#######################################################################################] 100%
:: Running post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…
[chris@chris-pc ~]$ EDITOR=‘kate -b’
[chris@chris-pc ~]$ SUDO_ASKPASS=/usr/bin/ksshaskpass
[chris@chris-pc ~]$ SUDO_ASKPASS=/usr/bin/ksshaskpass sudo edit -A %aCurrent%
[sudo] password for chris:
edit: illegal option – A
Usage: edit [- | -s] [-l] [-L] [-R] [-r [file]] [-t tag]
[-v] [-V] [-w size] [+cmd | -c cmd] file…
[chris@chris-pc ~]$ EDITOR=‘kate -b’
[chris@chris-pc ~]$ SUDO_ASKPASS=/usr/bin/ksshaskpass sudo edit -A %aCurrent%
[sudo] password for chris:
edit: illegal option – A
Usage: edit [- | -s] [-l] [-L] [-R] [-r [file]] [-t tag]
[-v] [-V] [-w size] [+cmd | -c cmd] file…
[chris@chris-pc ~]$ sudo edit -A %aCurrent%
edit: illegal option – A
Usage: edit [- | -s] [-l] [-L] [-R] [-r [file]] [-t tag]
[-v] [-V] [-w size] [+cmd | -c cmd] file…
[chris@chris-pc ~]$

[chris@chris-pc ~]$ EDITOR=‘kate -b’ SUDO_ASKPASS=/usr/bin/ksshaskpass sudoedit -A %aCurrent%
bash: -b’: command not found
[chris@chris-pc ~]$

OMG

Krusaders ActionManager Entry!
EDITOR=‘kate -b’ SUDO_ASKPASS=/usr/bin/ksshaskpass sudoedit -A %aCurrent%

And where do I find the Krusaders ActionManager Entry!
I’m still finding my way around linux lol, their is still much I don’t understand

Did you check for config in root home directory?
Aka /root/.config

For security reason… as x11 is not really secure

Yes I went into the config file I couldn’t find anything relating to start to tray

In Krusaders (GUI) Preferens.

:sunglasses:

Well there seems to be two sets of preferences, one when you’re in non root mode, and one when you are in route mode and it opens in a separate window, I can’t access those preferences because I can’t get into root mode, because changed it to start in tray, and I can’t figure out how to get it off of that, if I could get root mode open in the separate window which it usually does I could change my preference back to where I want it, but I can’t figure out how to get it root mode displayed

give up…