Krunner not launching applications

My krunner started misbehaving. It only launches some apps.

  • Goneovim - did start
  • Firefox - did not start
  • Kitty - did start
  • LO Writer - did not start
  • Spot (GTK Spotify client) - did not start
  • VSCodium - did start

If I run krunner --replace, then all of the above work. Kicker (or whatever it’s called) does not have a problem with starting any app. I tried deleting krunnerrc and krunner cache files. No effect. Journalctl says this when tring Spot and LO Writer:

spot[1885]: Locale not supported by C library.
                    Using the fallback 'C' locale.
krunner[1885]: thread 'main' panicked at 'Failed to initialize GTK', src/
krunner[1885]: note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace
systemd[985]: Started Spot.
kwin_x11[1068]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 7238, resource id: 88080497, major code: 18 (ChangeProperty), minor code: 0
kwin_x11[1068]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 7242, resource id: 88080498, major code: 18 (ChangeProperty), minor code: 0
systemd[985]: tracker-extract-3.service: Deactivated successfully.
systemd[985]: Started LibreOffice Writer - Word Processor.
kwin_x11[1068]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 9724, resource id: 88080536, major code: 18 (ChangeProperty), minor code: 0
soffice.bin[1910]: Locale not supported by C library.
                           Using the fallback 'C' locale.
krunner[1910]: /usr/lib/libreoffice/program/soffice.bin X11 error: Can't open display:
krunner[1910]:    Set DISPLAY environment variable, use -display option
krunner[1910]:    or check permissions of your X-Server
krunner[1910]:    (See "man X" resp. "man xhost" for details)
systemd[985]: app-libreoffice\x2dwriter-548c6e46b1ed45d5946526fb31aa8e45.scope: Deactivated successfully.
kwin_x11[1068]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 10259, resource id: 92274689, major code: 15 (QueryTree), minor code: 0
kwin_x11[1068]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 10298, resource id: 88080537, major code: 18 (ChangeProperty), minor code: 0

I’m running plasma 5.21.5 with KDE frameworks 5.82.0. Kernel 5.12 and x11 as you see above. Single monitor. inxi output:

System:    Kernel: 5.12.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: HUAWEI product: KPL-W0X v: M1D serial: <filter> 
           Mobo: HUAWEI model: KPL-W0X v: M1D serial: <filter> UEFI: HUAWEI v: 1.19 date: 01/11/2019 
Battery:   ID-1: BAT1 charge: 50.2 Wh (100.0%) condition: 50.2/56.3 Wh (89.1%) volts: 8.5 min: 7.6 model: DYNAPACK HB4593R1ECW 
           status: Full 
CPU:       Info: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen rev: 0 cache: 
           L2: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31948 
           Speed: 1836 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz): 1: 1836 2: 1445 3: 1939 4: 1559 5: 1394 
           6: 1388 7: 1409 8: 1848 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Huawei driver: amdgpu v: kernel 
           bus-ID: 03:00.0 
           Device-2: Quanta hm1091_techfront type: USB driver: uvcvideo bus-ID: 3-1:2 
           Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.12.9-1-MANJARO LLVM 12.0.0) v: 4.6 Mesa 21.1.2 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Huawei 
           driver: snd_hda_intel v: kernel bus-ID: 03:00.1 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Huawei 
           driver: snd_pci_acp3x v: kernel bus-ID: 03:00.5 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Huawei driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.6 
           Sound Server-1: ALSA v: k5.12.9-1-MANJARO running: yes 
           Sound Server-2: sndio v: N/A running: no 
           Sound Server-3: JACK v: 1.9.18 running: no 
           Sound Server-4: PulseAudio v: 14.2 running: no 
           Sound Server-5: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel bus-ID: 01:00.0 
           IF: wlp1s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-2:2 
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 321.96 GiB (34.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB 
Partition: ID-1: / size: 906.94 GiB used: 321.96 GiB (35.5%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 51.5 C mobo: 0 C gpu: amdgpu temp: 51.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 269 Uptime: 19m Memory: 6.75 GiB used: 3.24 GiB (47.9%) Init: systemd Compilers: gcc: 11.1.0 
           clang: 12.0.0 Packages: 1811 Shell: Zsh v: 5.8 inxi: 3.3.04 
1 Like

Hi @wilmhit ,
Welcome to the forum!
I could see in the inxi output that you are using two monitors. Please, confirm it.
Then, I wonder whether you could post the output of the following terminal command:
journalctl -b -1

Also, you can read the following posts in order to solve your problem. Maybe the answer of @Aragorn and @Tc001 help you.
Very frequent freezes(3 during the writing of this topic) - #2 by Aragorn

Manjaro forces dedicated GPU when adding an external monitor

Hope this help, regards.

1 Like

Unfortunately I cannot post full boot journal. Relevant part is shown in main post. Also I cannot see how Aragon’s and Tc001 replies are helpfull. I am using single monitor. I had hdmi plugged in when I was running inxi. That is not usually the case.

Meanwhile I did some snooping around. Problem seems to be related to Xorg sockets. By running strace I can see now that programs seem to expect file /run/user/1000/:0. This file is not present on my system. who shows that I am in fact using display :0.

xhost access control is disabled.

I don’t really know what is suppose to be in Xauth, but I noticed something weird. My XAUTHORITY variable is pointing to /tmp/xauth-<something here> instead of $HOME/.Xauthority. Is that normal?
.Xauthority file gets created in my home directory at login even if I removed it. By using xauth I can see that contents of both files are identical.

After last plasma 5.22 update I switched to wayland, but I would like to solve this problem whatsoever, in case I need to go back to using Xorg.

Found it! The key was GDK_BACKEND env var. My .zshrc had this:

if [ $XDG_SESSION_TYPE = "wayland" ]
    export GDK_BACKEND=wayland

I don’t know why this does not work, but it executes this if on x11 sessions.

This does not sound right: these exports should be set if the session type is wayland.

1 Like

Then something else sets this var wrong.

I tested it with deleted export GDK_BACKEND line in .zshrc and after reboot it sets echo $GDK_BACKEND returns wayland even on x11 sessions.

This is weird. /etc/profile is untouched. I wonder what it could be?


should yield x11 on X11 and wayland on Wayland.

should yield x11 on X11 and wayland on Wayland.

This works as expected.

Now GDK_BACKEND is not exported anywhere I know. I deleted previous if statement. Either way, after fresh login echo $GDK_BACKEND yields wayland no matter what session I’m in.

Another hit! Grepped my whole home dir for GDK_BACKEND (took a while) and found it in ~/.config/environment.d/envvars.conf. Everything is now back to normal.

For searchibility adding this:
GTK Firefox LibreOffice x11 Xorg

** Gtk-WARNING **: cannot open display: 0.0

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.