Krunner freezes if first character is = sign

krunner freezes when typing = sign as its first character. The = sign can be used after, as long as it is not the first character. I can use for instance 2+2=, but if I start with = it just freezes. krunner just sits open, frozen and I can still use the system while is shows on the screen. When frozen, I have tried to kill the process but it doesn’t die… Eventually, something like a minute of two, krunner restarts and it becomes usable again.

I am running stable KDE and I am happy to provide any information that might be useful, just tell me what code to run, etc.

Hi @danoselti

Can’t confirm that but something similar has been reported upstream with bug report 454130.
A few things to try for you:

  1. Clear Krunner history in System Settings > Search > Plasma Search > Clear History > For all activities
  2. Deactivate Calculator plugin in Krunner settings: System Settings > Search > Plasma Search > Calculator and also Unit conversion = off
  3. If the issue still happens then open terminal and run: krunner --replace and see if you get a crash output.

Please also read details of upstream bug report and follow the progress. It will eventually get fixed by KDE.

I just tried it. No problem here. A specific config thing?

Not sure what plugins I am using.

I actually can reproduce it. It doesn’t happen immediately when you type =. When you type = followed by letters and you type very very fast, then krunner crashes.
Deactivating the calculator plugin in settings helps in my case.

1 Like

Thanks for the quick reply everyone

It seems to be related to bug report 454130 although in my case it just freezes and it is more likely to happen if I start a string calling Calculator plugin (invoking =) from the start. It is something related to this plugin it seems.

  1. Clearing history temporarily resolved the issue. I was able to reproduced it again by chance but now is less frequent
  2. I actually use Calculator a lot so I will try to leave it on. I can do some queries without having to type =
  3. Once it becomes more frequent I will try the krunner --replace command to try to capture a crash output