Krunner and kfind not working properly on manjaro kde

the kfind search on desktop doesnt show all files with the name I have searched for. It shows 2 to 3 set of fixed files even on different search.
the extended search on app launcher menu acts similar (app search is fine, problem with file search)
I have tried to reinstall kfind and krunner but without any effect.
plasmashell --replace doesnt solve the problem
I have tried reindexing using kde’s graphical indexing monitor.
balooctl purge followed by balooctl enable also have no effect (although balooctl monitor shows a 176 mb of index file).
however catfish search works fine. so it should be a more of a kde problem…
any clue?
the desktop search facility is really convenient as there is no need to hit the enter button to view search results.
i would have used catfish but it doesnt have the realtime search during typing.
device: thinkpad e14 i3 10th gen

Hi @arnab

Welcome to the community :slightly_smiling_face:

The issue is related to KDE desktop environment.
Please report it on KDE forum.

1 Like


If you have two indexing services running, then one will fail.

Baloo can also fail if you added a specific location to ignore list, or no indexed list. Search is capable to index even dotfiles, aka hidden files if you thick that check mark.


Also, not sure if this changed, but baloo si not indexing NTFS.

On my end there is no issue, so i can’t say there is a general KDE Plasma bug, but rather something wrong on your install.

1 Like

yeah… indexing is enabled as it shows in the pic.
i tried to uninstall catfish and its dependenies to nullify the chances of conflicting indexing services… no effect.
for experiment i removed my pdf files from the harddrive (cut paste to pendrive).
then reindexed and restarted.
it seems krunner is depending on a old index as it shows same results after reindexing… shows up the non existent files.
there is no ntfs partition on my drive…
at this point i also feel that it may be a faulty installation.
anyway i would try to reinstall manjaro and check it the problem persists…
is there a way to check all the indexing services that are running ?
thank you so much for your help.

Is a KDE Plasma background service

Can be disabled or enabled at startup. Never had any issues with it.
If you already removed the ~/.local/share/baloo/ and then manually started the indexing and it finished, it should be all fine. Otherwise there might be something it escapes us.

1 Like

i just ensured… it is indeed running.
balooctl is also running fine… it has a valid index , infact dolphin search is working fine.
it seems krunner is not utilising its indexing dependencies. it is stuck at the old index.
krunner --replace doesnt help either.

going for a fresh install.
coming right back …
may be i should go for the good old xfce

Booted in my testing install as i was in Gnome when i first replied, and made a few tests. It seems to be a regression or fault in the Places and Locations modules of KRunner.
I was also able to reproduce partially in the KDE Plasma GIT version. That means a reinstall might not help.

Give me some time to look around, if nobody else will have an idea or know about it.

1 Like

ok, i will be waiting …
using catfish untill then .
not that it is a big problem.
thank you very much

Well, not much information about it, but here is what i did:

  • removed all the locations i added to the Search settings, and rebooted the system
  • added back the custom locations and let the indexing finish, then rebooted the system

Is not as efficient as from Dolphin, but works.

1 Like

did what you said.
it still uses the same index. gonna use catfish now on .
thanks a lot.