Krohnkite 'bug'

I’ve noticed an issue using Krohnkite - use Super+W to maximise the window. If you have it in your decoration, you’ll see the ‘always on top’ button enabled. It stays enabled when you restore. This is a pain for Firefox with no titlebar (it stays on top permanently even if you maximise and unmaximise it).

With GIMP it’s a problem because the preferences window opens hidden behind the pinned main window.

Is there any way to control this? I don’t want ‘always on top’ being enabled… it means I couldn’t pull a dolphin window to the front to drag and drop a file, for example.

You need to set the Options like this


Restart the session after that.
Then you can manually set what window to Keep above

No, my settings already look that way.
I am unable to stop windows being always on top after having been maximised. It seems to be the way Krohnkite works and not something affected by settings…

Windows i have maximized do not stay on top.

This are my Rules:



This are my active Layouts:


Nothing else is enabled. The geometry is not important for our case here.

Wow, spiral layout - interesting.
I’m curious if I have set this somewhere else. Hmmm maybe I should go make a new user and play around some more if this isn’t normal.
Plasma settings goes deep - I can’t find this in kwin or in krohnkite settings.
No window rules or anything…
But I see ‘spiral’ in my ‘test’ user, so I’m sure it’s something in my .dot files - maybe time to rename some folders.
Thx - I’ll report back when I nail it down.

Wow. I did -Rns and installed via settings - but no settings for krohnkite appeared, so I removed it and opened terminal starting with -Rns.

kwin-scripts-krohnkite-git r464.2a47753-1 [installed] [11+] [0.61%] [13 Jan 2021]

NOW I have spiral… interesting layout. I can’t imagine why I didn’t have it before…

I need to exclude settings, as that window always misbehaves; though I generally ‘F11’ it to a new desktop.

Right now I can maximise it and unmaximise - no problem.

However, now when I cycle to Floating (Meta + ) when I get to floating, everything is set to be always on top… So then I went back to the settings (set Floating windows on top) and this time when I unset this option, it returned to what I previously wanted.

So in the end it’s solved - but beyond a ghost in the machine I can’t really say why.
I’ll mark you for the solution, your screenshots led me to the answer in the end :wink: Thank you.