Konsole prompt gone haywire

what is that god-awful new prompt in konsole? How do I restore sane

What do you mean? I am fully updated and Konsole is the same for me as it always was. Maybe give us a screenshot or something?

The command prompt has nothing to do with Konsole, but is set by whatever your interactive shell is, and is defined in the shell’s initialization file. If you are running a fairly new installation, then the default interactive shell is zsh. If you installed your system a longer time ago, then the default interactive shell will still be bash.

First issue the following command to determine what shell you’re running… :arrow_down:

echo $SHELL

Then look at the shell’s initialization file. For bash, that will be ~/.bashrc and ~/.bash_profile. For zsh, it is ~/.zshrc.

Now, I’m not very familiar with zsh, but in bash, the prompt is defined by the variable $PS1. For zsh, Manjaro uses a very special theme, and it is this theme that sets your prompt.

1 Like

thanks for all the help; right you are: something changed bash to
zsh in Breath.profile … an unpleasant and unrequested change
to start my Saturday

chsh -s /bin/bash


actually, that did not work; I had to manually change the Breath.profile file

I was just mucking about with this too. It’s weird that the default shell is set in the system theme. My /usr/share/konsole/Breath.profile contained:



I had to delete that Command=/bin/zsh line to get Konsole to use the default shell specified in /bin/passwd. I don’t think that is supposed to be there.

1 Like

Manjaro GNOME provides zsh by default for some time already. KDE edition was also using it for new users since August. Now I just restructured our configuration stuff and put zsh in separate profile configured system-wide. So if you are using default configuration you now having a new profile.

in what profile, what files exactly?

What do you mean with default configuration?

I use KDE, old install, shell is still bash but I have


in /usr/share/konsole/Breath.profile as well.

I have Breath theme selected but the shell is not changed to zsh (which is fine) in konsole, why? Should the line better be deleted?

Profile is in /usr/share/konsole/Breath.profile
Config is in /etc/xdg/konsolerc

Config that is set in /etc/xdg/konsolerc. Previous Breath2.profile configuration was there, now it’s replaced with Breath.profile, so if you didn’t overrode this in local configuration (by setting a different profile in Konsole settings) you were using the default global one.

I think you are using local config, check ~/.config/konsolerc

My konsolerc does not contain anything related to the shell, I think:

[Desktop Entry]

[Favorite Profiles]


Maybe the emtpy DefaultProfile= setting makes the difference.

Yeah, this could be a reason. I think Konsole defaults to /etc/xdg config only if no corresponding setting found locally. In this case it’s there just empty so it might just use it’s internal one, which uses the login shell.


Just wanted to report that the latest round of updates did the same thing to me… somehow (I haven’t investigated) replaced BASH with ZSH. I lost my carefully-constructed prompt, and also lost all of my carefully-constructed aliases. The system seemed to be running smoothly, but was obviously not using ~/.bashrc.

I had a recent image back, so I just restored from that. Ran the updater again, this time answered NO to the questions about replacing the ‘breath’ package.

I’m happy to report that BASH is back, with all of my tweaks.


That’s not lost. If you change the shell to be used explicitly to /bin/bash it’ll be “back”.

created an account just to like this post. what on earth convinced devs that deleting my current theme and replacing it with something uglier that also changed the theme of the konsole?

We didn’t delete anything. We just replaced default system settings that you were using. Your profile is still available and you can switch to it.

I must have been confused by the messages telling me “removing plasma theme” “theme not compatible”…