Kommandozeilen bei Systemstart & Herunterfahren


#1

ich versuche es hier, auf deutsch, da sich mein problem sowieso auf den kernel erweitert hat.

das intermezzo zuvor:

wollte eigentlich dieses “backlight” problem lösen. aber nach dieser einstellung:

frierte das system ein. irgendwie kam ich dann noch noch rein und habe per terminal wieder alles auf den ursprung gesetzt:

problem: seitdem fährt das OS nicht mehr runter, ohne vorher eine menge kommandozeilen anzuzeigen. das gilt auch für den systemstart. es ist nicht mehr so, wie vor der besagten konfiguration, wo mir nur der kleine “backlight” - fehler beim hochfahren angezeigt wurde - dann kam gleich der anmeldebildschirm.

wie lässt sich das ohne neuinstallation lösen? für das ürsprüngliche aber nun eher sekundäre backlight - problem habe ich - vermute ich als newbie - bereits hier eine lösung:

aber das ist jetzt nicht wichtig.

müde, ausgelaugte grüsse,
noe


#2

Hast du danach auch ein

sudo update-grub

durchgeführt?


#3

Hört sich so an, als ob du den flickerfree boot vermissen würdest:

Von hier:

  1. How to enable hidden GRUB menu?

On new Manjaro v18.0 installs this will be enabled by default. If your system has been upgraded to v18.0 from an older release, you can enable it by running these commands:

  • update your system to get latest systemd
  • install linux418 or linux419 : sudo pacman -S linux41[x]
  • check that you have quiet in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT or GRUB_CMDLINE_LINUX and comment out any GRUB_BACKGROUND settings.
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent
  • You may want to consider early kms and fastboot for intel hardware
  • sudo mkinitcpio -P
  • sudo grub-editenv - set menu_auto_hide=1
  • sudo update-grub
  • reboot your system

Ich denke der relevante part ist:

sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent
sudo mkinitcpio -P
sudo grub-editenv - set menu_auto_hide=1
sudo update-grub
reboot your system


#4

@admdb

yep, habe ich.

@firefightux

ich habe jetzt nur

sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent

durchgeführt. es wurde erkannt, daß das bereits läuft und wurde re-installiert. danach habe ich sudo update-grub durchgeführt - zur vorsicht … . nach neustart ist alles eingefroren, abgewürgt, wieder gestartet, läuft wieder.

aber die komandozeilen am anfang wie am ende sind immer noch da.

soll ich wirklich noch zusätzllich:

sudo mkinitcpio -P
sudo grub-editenv - set menu_auto_hide=1
sudo update-grub

durchführen, inklusive nochmal vorher

sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent

?

oder liegt es an einem deaktivieren dienst?

systemctl list-unit-files --type=service 
accounts-daemon.service                     disabled       
acpid.service                               disabled       
alsa-restore.service                        static         
alsa-state.service                          static         
auditd.service                              disabled       
auth-rpcgss-module.service                  static         
autovt@.service                             enabled        
avahi-daemon.service                        enabled        
avahi-dnsconfd.service                      disabled       
blk-availability.service                    disabled       
bluetooth.service                           enabled        
btrfs-scrub@.service                        static         
canberra-system-bootup.service              disabled       
canberra-system-shutdown-reboot.service     disabled       
canberra-system-shutdown.service            disabled       
clean-mount-point@.service                  static         
colord.service                              static         
configure-printer@.service                  static         
console-getty.service                       disabled       
container-getty@.service                    static         
cpupower.service                            disabled       
cronie.service                              enabled        
cups-browsed.service                        disabled       
dbus-org.bluez.service                      enabled        
dbus-org.freedesktop.Avahi.service          enabled        
dbus-org.freedesktop.hostname1.service      static         
dbus-org.freedesktop.import1.service        static         
dbus-org.freedesktop.locale1.service        static         
dbus-org.freedesktop.login1.service         static         
dbus-org.freedesktop.machine1.service       static         
dbus-org.freedesktop.ModemManager1.service  enabled        
dbus-org.freedesktop.NetworkManager.service enabled        
dbus-org.freedesktop.nm-dispatcher.service  enabled        
dbus-org.freedesktop.portable1.service      static         
dbus-org.freedesktop.timedate1.service      static         
dbus.service                                static         
debug-shell.service                         disabled       
dhclient@.service                           disabled       
dhcpcd.service                              disabled       
dhcpcd@.service                             disabled       
display-manager.service                     enabled        
dm-event.service                            static         
dmraid.service                              disabled       
dnsmasq.service                             disabled       
emergency.service                           static         
fancontrol.service                          disabled       
flatpak-system-helper.service               static         
fstrim.service                              static         
ftpd.service                                disabled       
geoclue.service                             static         
getty@.service                              enabled        
git-daemon@.service                         static         
gpm.service                                 disabled       
grub-boot-indeterminate.service             static
ssproxy.service                            disabled       
haveged.service                             disabled       
healthd.service                             disabled     

#5

sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent hat kaum Sinn nochmals auszuführen. Da die Änderungen in mkinitcpio.conf noch vorhanden sein sollten und systemd-fsck-silent ja installiert ist.
Du musst mindestens sudo mkinitcpio -P damit die Änderungen mit sed aus /etc/mkinitcpio.conf umgesetzt werden (wenn du hier mehr wissen willst schlag in man mkinitcpio nach). Das andere sollte nur grub betreffen. Du wirst dann halt immer das Grub Menü sehen, da

sudo grub-editenv - set menu_auto_hide=1
sudo update-grub

das auto-hide von grub aktiviert.


#6

… dann führe ich jetzt nur noch

sudo mkinitcpio -P 

aus und starte das system neu … . sehen wir mal, was passiert. mich kann nichts mehr überraschen ;).

edit: hat leider nichts gebracht…


closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.