Kodi crash possibly linked to KDE Plasma 5.14.21-2 database error & manjaro update

Hi, i recently installed a manjaro up date part of which was kodi update, when i installed this i ended up with kodi not working properly and continually freezing up. I have removed and reinstalled kodi via add and remove but still the same issue. just before this update happened i was getting a message that there was a database error, not sure if this has anything to do with this issue. I am using an acer laptop with kodi 19.3Operating System: Manjaro Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.14.21-2-MANJARO (64-bit)
Graphics Platform: X11
Processors: 2 × Intel® Pentium® CPU 2020M @ 2.40GHz
Memory: 5.6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 2500

Any advice would be much appreciated? is it possible to undo an update not using timeshift.

I’m not saying it has anything to do with your issue, but kernel 5.14 is “End of Life”, you should switch to another one like 5.15 or 5.10 LTS. Also, fully update by

sudo pacman-mirrors -f && sudo pacman -Syyu

and reboot afterwards.

I’m experiencing the same problem, based on my research the update of python clashed with some if the kodi scripts. I ended up deleting my .kodi folder and installed kodi fresh. With the basic skin and no adding addons kodi is running again.

My problems returned when I installed the embuary skin again, to many scripts relying on an earlier version of python.

Unable to get a workable Koid/Python combination. My work-around was to install Kodi in a flatpack.

Command line instructions
Install: flatpak install flathub tv.kodi.Kodi
Run: flatpak run tv.kodi.Kodi

1 Like

Thanks for your good suggestions however, i followed wollies and set as 5.15 and fully up dated that worked fine. I then installed kodi using the flatpak install, when i run kodi everything installed fine and i had to input a new build so i chose Cman which appeared to install ok i rebooted and ran kodi the build came up with a full page showing the Cman logo and thats as far as i can go? the arrow moves pefectly but there is no where to go further. I am unable to remove these files and re-install also a error message appears in the konsol
app/tv.kodi.kodi/x86_64/master not installed. Can’t find a way to install master, any suggestions would be appreciated. Your comments above have been very helpful thanks. ian

Hi there.
I struggled with the same problem.
Seems kodi has some problems with the newest python update. Or the other way around :).
Anyways, solution for me was to go back to python 3.10.
Have a look over here:

Have a nice day.

Thanks onigin, i will look at that, being a newbie how do i go back to python 3.10… Also when i start manjaro when it comes up clean files at the end it displays an error message PKG file database Failed would this point to a python issue??.


Just followed instruction to install 3.10 looked good but failed to install at the end

Thanks for your advise re-installed manjaro and installed flatpak kodi,this didn’t work so installed via add/remove was able to get kodi up and running with a build then it crashed.

@newbee what worked for me was deleting the .kodi folder and freshly installing kodi, just running it in the default skin, and staying away from any scripts. It’s not what I normally want to run, but it runs stable.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.