Kodi and booting Manjaro

on 12/15/2019 i installed kodi (18.5-1 community) in manjaro 18.1.4 rc2 kde 64 bit testing build, this was after i installed several other pieces of software from manjaro's software center. after i installed kodi i launched it and set it for windowed., and then closed kodi and rebooted the system. once it rebooted i was presented with the kodi home screen and no apparent way to boot to my desktop. try as i might to get kodi to shut down as normal with kodi it didn't want to exit. i finally did a hard reboot and once again was presented with kodi. this time when i clicked kodi's power button i waited remembering that it can take kodi awhile to close. finally kodi close and i was presented with my manjaro login screen, gut when i entered my password i was taken right back to kodi. i did this routine 3 or 4 more times before i noticed in EXTREMELY tiny text in the bottom left corner that i had a menu to select either kodi or manjaro., so i selected manjaro, entered my password and FINALLY ended up on my desktop. once there for the time being i uninstalled kodi. i want to reinstall it, but i need to make sure it's not going to do that again. i also want to make sure kodi is not running in the background when i don't have it open. thanks

https://forum.kodi.tv/showthread.php?tid=350152&pid=2908808#pid2908808

when you get to the SDDM login screen you need to change the session from kodi to kde/plasma before logging in.

as i when i rebooted i was immediately greeted with the kodi home screen not the actual login screen. finally after some fiddling around i at least got kodi into the windowed mode, and then notice the options in the bottom left corner to chose rather i wanted kodi or the desktop. there must be a setting in kodi where i disable this behavior so i'm always presented with the login screen and it boots to the desktop not kodi once i enter my password. i honestly would just like for kodi not to have the function at all, cause i like using auto

just updated my thread at:

https://forum.kodi.tv/showthread.php?tid=350152&pid=2908808#pid2908808

i read it but kodi doesnt set itself as the default xsession, that had to be something you did. i dont suppose you have autologin enabled?

if you do, check /etc/sddm.conf.d/autologin.conf and see what .desktop it points to and change it back to plasma.desktop if it's not already.

it is not something i did. as i've stated installed kodi, launched kodi, set it for windowed mode, installed the titanium addon, closed kodi, did a few task(none of which had to do with any settings in plasma or manjaro), rebooted and was presented with the kodi homescreen. yes i use auto login. thanks for finally the one to point me at something i can actually look at.

disable auto-login > install/run kodi > reboot > select kde/plasma as a sesson and login > re-enable auto-login. there should be no need of manually editing anything if you do it that way.

2 Likes

yes yes and yes, that did the trick, thank you very much.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by