kitty terminal mouse cursor

I am getting a right & up pointing black arrow, it is not using my plasma or GTK theme, any ideas if I can change it? My internet foo is weak.

How long have you been using kitty? Did this just start?

  1. Powerline config?

  2. zsh config?

  3. Wm/DE themes/configs?

  4. You can also try:

XDG_CONFIG_HOME/kitty/kitty.conf

Look at

pointer_shape_when_grabbed

1 Like

Just started:

  • Oh-my-Zsh

  • As I said it is not following my Plasma/Plasma GTK settings

  • My kitty config is in ~/.config/kitty

  • pointer_shape_when_grabbed has no effect.

  • tmux on/off no difference.

Those were my only ideas. I don't use zsh, and run i3.

Sorry...

:frowning:

1 Like

I was trying it as a replacement for st, will look at alacritty next. Kitty doesn't like my autokey expansions, but other than it is pretty good.

I like it (kitty) because it uses my otherwise unused GPU. Added bonus: image viewing in ranger works OOB.

Autokey is a deal breaker for me, been using it for years. If I have the phrases:

xirconuk@gmail.com
| grep -i

in kitty I get:

xirconuk'gmail.com
\ grep -i

Will report on their github, but off out, will have to do tomorrow.

does anyone know how to fix it? i have exactly the same issue.

I didn't pursue it, I use alacritty instead.

i tried alacritty but it doesnt recognize my config file. i tried all three possible options they write about in their documentation but it didnt read it. googled it and it seems im not alone.

Mine is in ~/.config/alacritty works here. I have the git version installed though.

interesting. tried the git version and here it works with ~/.config/alacritty/alacritty.yml

it has one issue though. it flickers a lot in neovim. tried it with tmux and without

Sorry, that was just the directory, so the config file is as you state. I don't use vim, emacs all the way :smiley:

But I do use tmux:

Nvim seems OK here. Now I just need to remember how to quit :rofl:

2 Likes

i found the answer. u can change the cursor using pointer_shape_when_grabbed Beam

insteadt of beam there are other options too like block etc but for me beam looks best

Forum kindly sponsored by