Kibojoe Linux - Manjaro Linux re-spin with JWM [18.02rc5 is ready > 2018-03-19]



It works great live, but after I successfully installed it, [bare-metal], it would just hang on bootup, right after the line below:

[OK] ... ...
[OK] Started TLP system startup/shutdown
 --->  it hangs right here <---

-I had to pwr-cycle it, could not soft-boot it.

I was trying to install it as a tripleboot, along with Win10, LM, in uefi/gpt.

Also, although the uefi boot option successfully showed up as “Kibojoe”, via /boot/efi, and it did start booting, it got hung on where I mentioned above, crtl-alt-anything did nothing, and I could not even ctrl-alt-del out of it, as I mentioned above.

Anyway, that’s a shame, it may be something simple, or maybe not, I might try it again on a lone system.

TLP system restart/shutdown at boot


…vixi zero…

i had this problem “Starting TLP …” in live
i managed to solve with the help of @excalibur1234

you could test the new iso?


vlw fwi, Holmes :slight_smile:



I just tested your new iso, and
It still hangs after a successful uefi/gpt installation, as explained in my above post.
(However, it did install successfully on a Legacy-Bios/MBR system.)

Also, I noticed no Xorg logs in /var/log/…, which makes sense since it never gets to the desktop?.

Anyway, I’m up for a bit of testing so let me know what you want,
dmesg. lsblk, log outputs?

Oh dear, where is “Gparted” and “gdisk” here !?, comon’ dude, you gotta atleast include gdisk in your iso. :wink:

I ran pacman -Syyu, installed some tools, and tried a fresh uefi/gpt install, with the newer iso again, while typing this post, and this time it spewed the output below, just as it finished installing:
(cut-n-pasted the below from the Calameres Error window:

Installation Failed
Boost.Python error in job "bootloader".
<class 'subprocess.CalledProcessError'>
Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Kibojoe --force' returned non-zero exit status 1.
  File "/usr/lib/calamares/modules/bootloader/", line 334, in run

  File "/usr/lib/calamares/modules/bootloader/", line 305, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File "/usr/lib/calamares/modules/bootloader/", line 236, in install_grub

  File "<string>", line 2, in <module>

Maybe there should be a proper Calameres output log in /var/log/… ?

df -h:

Filesystem      Size  Used Avail Use% Mounted on
dev             7.9G     0  7.9G   0% /dev
run             7.9G   92M  7.8G   2% /run
/dev/sdc1       903M  903M     0 100% /run/miso/bootmnt
cowspace        256M     0  256M   0% /run/miso/cowspace
overlay_root     12G  538M   12G   5% /run/miso/overlay_root
/dev/loop0       60M   60M     0 100% /run/miso/sfs/livefs
/dev/loop1      110M  110M     0 100% /run/miso/sfs/mhwdfs
/dev/loop2      275M  275M     0 100% /run/miso/sfs/desktopfs
/dev/loop3      365M  365M     0 100% /run/miso/sfs/rootfs
overlay          12G  538M   12G   5% /
tmpfs           7.9G     0  7.9G   0% /dev/shm
tmpfs           7.9G     0  7.9G   0% /sys/fs/cgroup
tmpfs           7.9G  2.4G  5.5G  31% /tmp
tmpfs           7.9G  1.6M  7.9G   1% /etc/pacman.d/gnupg
tmpfs           1.6G  8.0K  1.6G   1% /run/user/1000
/dev/sda2        96M   29M   68M  30% /tmp/calamares-root-jq88e1l3/boot/efi
tmpfs           7.9G     0  7.9G   0% /tmp/calamares-root-jq88e1l3/run


loop0    7:0    0  59.4M  1 loop /run/miso/sfs/livefs
loop1    7:1    0 109.5M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0 274.7M  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 364.5M  1 loop /run/miso/sfs/rootfs
sda      8:0    0   1.8T  0 disk 
|-sda1   8:1    0   450M  0 part 
|-sda2   8:2    0   100M  0 part /tmp/calamares-root-jq88e1l3/boot/efi
|-sda3   8:3    0    16M  0 part 
|-sda4   8:4    0 994.6G  0 part 
|-sda5   8:5    0  14.9G  0 part 
|-sda6   8:6    0 670.5G  0 part 
|-sda7   8:7    0   9.8G  0 part 
`-sda8   8:8    0  78.1G  0 part 
sdb      8:16   0   2.7T  0 disk 
`-sdb1   8:17   0   2.4T  0 part 
sdc      8:32   1  59.6G  0 disk 
|-sdc1   8:33   1   903M  0 part /run/miso/bootmnt
`-sdc2   8:34   1    46M  0 part 
sr0     11:0    1  1024M  0 rom  


> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0300:1002:683f) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
        video-catalyst            2017.03.12               false            PCI
             video-ati            2017.03.12                true            PCI
            video-vesa            2017.03.12                true            PCI


Well, I guiess I should NOT have run pacman -Syyu prior to the previous installation. -haha.

So, I tried one more bare-metall install, and it, ehm, successfully? installed in uefi/gpt, but it hung again, at the same place, after a restart,:
“Started TLP system …”, as mentioned in my above post.
While it was hung, this time, I opened another tty/console and got some mountpoints, and logs:

$efibootmgr -v
BootCurrent: 0003
Timeout: 3 seconds
BootOrder: 0003,0001,0000,0002
Boot0000* Windows 10	HD(2,GPT,0cf1204b-5420-4782-af16-1195937931a6,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0001* Mint-18.1	HD(2,GPT,0cf1204b-5420-4782-af16-1195937931a6,0xe1800,0x32000)/File(\EFI\Mint-18.1\shimx64.efi)
Boot0002* UEFI: Lexar USB Flash Drive 1100	HD(1,MBR,0x51fba876,0x13c,0x17000)/File(\EFI\BOOT\BOOTX64.EFI)AMBO
Boot0003* Kibojoe	HD(2,GPT,0cf1204b-5420-4782-af16-1195937931a6,0xe1800,0x32000)/File(\EFI\Kibojoe\grubx64.efi)
Filesystem      Size  Used Avail Use% Mounted on
dev             7.9G     0  7.9G   0% /dev
run             7.9G  860K  7.9G   1% /run
/dev/sda8        77G  2.5G   70G   4% /
tmpfs           7.9G     0  7.9G   0% /dev/shm
tmpfs           7.9G     0  7.9G   0% /sys/fs/cgroup
/dev/sda2        96M   29M   68M  30% /boot/efi
tmpfs           7.9G     0  7.9G   0% /tmp
tmpfs           1.6G     0  1.6G   0% /run/user/1000
System:    Host: kibojoe Kernel: 4.9.22-1-MANJARO x86_64 (64 bit) Console: tty 0 Distro: Kibojoe Linux
Machine:   Device: desktop System: Gigabyte product: N/A
           Mobo: Gigabyte model: 970A-UD3P v: x.x UEFI: American Megatrends v: FC date: 02/26/2016
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB 
           clock speeds: max: 3500 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz 5: 1400 MHz 6: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E]
           Display Server: 1.19.3 driver: modesetting
           tty size: 169x52 Advanced Data: N/A for root out of X
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.22-1-MANJARO
Network:   Card-1: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlp3s0 state: down mac: aa:11:63:86:39:f3
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: fc:aa:14:cd:dc:c3
Drives:    HDD Total Size: 5065.0GB (3.8% used)
           ID-1: /dev/sda model: ST32000641AS size: 2000.4GB
           ID-2: /dev/sdb model: ST3000DM001 size: 3000.6GB
           ID-3: USB /dev/sdc model: USB_Flash_Drive size: 64.0GB
Partition: ID-1: / size: 12G used: 17M (1%) fs: overlay dev: N/A
Sensors:   System Temperatures: cpu: 12.6C mobo: N/A gpu: 36.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 174 Uptime: 1 min Memory: 307.8/16018.0MB Init: systemd Client: Shell (bash) inxi: 2.3.8 

^ Strangely enough, everything looks and seems fine above, but then I saw the below:

** Message: find greeter (nil)

** Message: find idle (nil)

** (process:474): CRITICAL **: exec /usr/bin/X fail

** Message: quit code 0

** Message: exit cb

** Message: free session


Also, There really wasn’t much to see in either dmesg, or journalctl that could tell me WHY it hangs at that point ?!
And again, as a side-note, as I mentioned before, when I tried a bare-metal install on a Legacy-bios/mbr system, it installed, and restarted fine.
So something is definitely borked afterwards in a uefi/gpt installation, but I have no idea what or why yet.?

Anyway, good luck with your “.iso’s” hombre, and Let me know when you get these fixed. :slight_smile:

I’m sorry but you people should be actually “testing” these iso’s completely, and beforehand, instead of crying “wolf” after the facts.

Unfortunately, every wannabe dev seems to lazily test everything in a VirtualBox. -well, there you go, VB just doesn’t cut it all, in the administarative real world, now does it ?
-so there you go.


@scjet thank you!

“Started TLP system …” it was happening at boot time, see

about the Calamares error i found this, see

i have no idea why these problems are occurring…

vlw fwi, Holmes :slight_smile:


as a guess, is there a systemd service that is not being enabled/started, that is preventing the system from continuing after “Started TLP system startup/shutdown” ?

The only things right after that, are, in order, roughly
wpa, lots of network-manager stuff, ntpd, dm/greeter, dbus,… -> upto graphical desktop.
LoL, -netwrok-manager is quite the bloated beast now.

There’s actually more than just that going on, but anyway, I did notice, on the same install/restart of “manjaro-kde-17.0.1-stable-x86_64.iso”, in uefi/gpt mode, that upon a restart it also hangs, for about 10 seconds, right after the “Started TLP system startup/shutdown” line, but then continues booting ok.

check your build again.


this is occurring with other isos (manjaro-kde-17.0.1-stable-x86_64.iso), the problem should be with uefi / gpt mode…

ays ago the boots of the jwm isows stopped in

“Started TLP system startup/shutdown”

to solve this, i left this in profile.conf file

enable_systemd_live=(‘manjaro-live’ ‘mhwd-live-net’ ‘pacman-init’ ‘mirrors-live-net’)

now boot work…

vlw fwi, Holmes :slight_smile:


Not exactly,
since I just did a test [bare-metal] install over your JWM, and as I mentioned in my previous post, with the
It restarted ok in uefi/gpt mode, although a bit slower than usual. -But after tweaking my wpa-supplicant country code, as well as that avahi/mDNS crap,…, it finally restarted faster, but anyway, that’s a separate User issue from your JWM iso build.

Well that’s good news.
geezus, no wonder some prefer the good 'ole simple and stable sysvinit/rc-init style startup scripts.
Systemd is an octopi nightmare just waiting to happen, again, and again, …

Hint: next time, you could also work with the manjaro-architect team, by importing your jwm-profile into m-a and the more heads the merrier ? :slight_smile:

Anyway, hope you solved it this time, and please gimme a shout when you have your next iso built, 'cause many of us would like to see JWM stick around for a long, long time.
Good work.


in the iso you tested (rc2) is with the grub-quiet
i created a new pkg called grub-quiet-kibojoe

is the problem with the name?

in the rc1 version I also changed the package name to grub-kibojoe

obs: i created a new pkg to change the manjaro-release to kibojoe-release…

vlw fwi, Holmes :slight_smile:


I dunno,
all my previous tests were done with your “kibojoe-17.04rc2-x86_64-code24417.iso”, as you instructed before.

Sooo, Did you actually fix your iso now ?
Is your newly fixed iso available, and does it restart successfully in uefi/gpt mode, … ?
Do you have specific startup commands that you would like to run for testing purposes? and on which iso?, and if so, please paste them ALL in easy-readable detail.
That’s it, my friend.

I’m just a “User” tester, and not a “Dev” tester here. -aka, the Dev’s are supposed to make this ■■■■ work



vlw fwi, Holmes :slight_smile:


hi all,
i would like to know if anyone had the same problem reported by @scjet

vlw fwi, Holmes :slight_smile:


I’m going to download and check it out. :grinning:


thank you @Beto

vlw fwi, Holmes :slight_smile:


@holmes Everything running fine on my end. Seems my machine likes Manjaro and JWM, always have good luck with them. Is it ok to put an installer on the desktop just incase some can’t find it for noobs like myself.
Enabling the menu for some while they need to refresh/change shortcuts or if they aren’t shortcuts savy, but if not it’s cool, everything good though. I use the same shortcuts like you have them anyway, but just saying, menu would be cool for lazy days. :grinning:


Really?, well that’s good news,
But for me, I can install and restart manjaro-kde-17.01 ok, but although Kibojoe will install, it’s a no go, when it comes to restarting into it again.


Hmmm, I don’t know, I just installed it on metal right now, everything seems fine @scjet


Using it as we speak, to me it seems better than the ones before.



interesting and good news…
then the boot is not standing still in

[OK] Started TLP system startup/shutdown

also without error with Calamares…
it works perfectly!

the stranger is the case of @scjet
i can not understand…

thank you @Beto

::::::::::>>> i hope someone else can install and report how it went <<<::::::::::

vlw fwi, Holmes :slight_smile:



I found the problem with your (bare-metal) latest Kibojoe, (uefi/gpt) install, and why it couldn’t restart into the Desktop , and therefore why it hung at:

I restarted into tty/cosole using “3” in boot options.
when I ran a yaourt -Syua, it said: "xorg-server dependencies required for lxde…"
Then I checked other missing pkgs with pacman -Q…, and upon a (bare-metal)-post-installation/restart.

Here’s the pkgs that were missing in post-install of kibojoe ?! :

xf86-video-ati -(even though the “lying” mhwd in kibojoe post-install, was trying to tell me that it was installed, see my above previous post).

xorg-server, xorg-server-common, …, and some other missing dependencies.

I know why it failed to come up after a restart, but I don’t know why ALL these pkgs were missing post-install?, -since obviously when booting in uefi “Live”-mode, everything was fine.

This also explains why now /var/log/lxdm.log outputs correctly:

(==) Log file: "/var/log/Xorg.0.log", Time: Tue May  2 11:34:07 2017
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
** Message: 1493739250: start xserver in 8 retry
** Message: add 0x2595e50

** Message: prepare greeter on /var/run/lxdm/lxdm-:0.auth

** Message: start greeter on /var/run/lxdm/lxdm-:0.auth

as opposed to the failed /var/log/lxdm.log in my previous post (below):

anyway, I manually installed the needed pkgs, and now Kibojoe comes up fine.

This is why I don’t trust doing testing solely in VM’s.
It’s iso testing 101 guys, that’s all it is.

>>> I hope this helps you guys fix it <<<

[MJ GNOME] Error Bootloader Job [UEFI]