Keyboard settings reset after suspend/restart

Not sure exactly why, but the keyboard settings I set from the Keyboard section of the XFCE settings panel get reset every time I resume from suspend, or when I restart the OS.
I can go back to the settings and adjust the slider, and the settings are applied again, but when I do a suspend, it goes back to the “defaults”.
It’s like XFCE has amnesia.

Does anyone have any idea what I could look into to fix this?

Set it in “Manjaro Settings”.

1 Like

It has the same settings as in the XFCE keyboard section. Will check again if the values change after suspend.

Anything else?

Nope. It is needed to write it to a X config. Default is /etc/X11/xorg.conf.d/00-keyboard.conf.

“Manjaro Settings” write it there with root privileges, while XFCE does not as I know. So the Xorg Config will overwrite XFCE Settings.

Well, tried to play a little bit with the sliders, but the config file stayed the same as it did before adjusting those.

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "euro"

You clicked on “apply” right? Also it needs a relog/reboot so that it gets applied.

I did click on apply, and I’ve gotten asked for the root password, which confirms what you were saying earlier.
The settings have been applied already, strangely. Or do you mean to say that a reboot is required for the changes to be applied to the config file?

Look: You set the config and now xorg needs to load it, therefore restart xorg, means: logout/login or reboot. Gotcha?

Nope, no gotcha, still the same issue.

After a few more days of getting frustrated at this problem, I tried to add a xset command in ~/.xprofile:

xset r rate 250 40

It works fine when I do a cold boot on the machine or if I restart it, but once I suspend it, the problem rears it’s ugly head yet again.

I had the same problem and just fixed it by editing /etc/X11/xorg.conf.d/00-keyboard.conf and adding Option "AutoRepeat" "200 30" as described under point 5.3 here:

It seems to be fixed, I can reboot, lock my pc and suspend it and the option persists.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.