Keyboard repeat rate resets after every reboot

Trying to permanently set my keyboard repeat rate
I have this in .xinitrc:

#!/bin/bash
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
xset r rate 90 90
[rest of default settings]

What am I doing wrong

I prefer to create a *.desktop file inside /.config/autostart/
For example to your case, i would create xset_fix.desktop with this content in it:

[Desktop Entry]
Name=xset_fix
Icon=system-run
Exec=xset r rate 90 90
Terminal=false
Type=Application

In case you are on Gnome, then maybe you need to add at the end also this line:
X-GNOME-Autostart-enabled=true

Thanks will give it a try

This didn’t work
On i3 window manager, if it makes a difference

Yes, it make a lot of difference. Add this to your i3config

# Configura keyboard repeat speed
exec --no-startup-id xset r rate 90 90

Somewhere where you have the other keyboard settings.

Thanks @bogdancovaciu, that worked