Keyboard problems on Alienware

I have an Alienware laptop and a new installation that is up to date. The only additions to the installation are Google Earth, Qbittorrent, AlienFX, Etcher and Calibre. My problem is my keyboard. Part of the keys no longer work such as enter, the letter i unless I bang on it and backspace. I have searched the forum, online, the Arch wiki and Googled the problem. My language packs are up to date. The last thing I did was try different kernels to see if that fixes the problem. It seems to help for a few minutes but once I use the keys mentioned, it stops working or the keys mentioned above work but others don’t. Hell, I even tried switching distro’s I’ve used in the past but then I lose my wifi and can’t seem to fix that either. I prefer Manjaro due to the available packages but I kinda need my keyboard. Any suggestions would be appreciated.

I may have fixed the problem. I’ll give it a day or so and see. What I did was change the kernel back to 5.4.112-1, then shut the system down and restart it. That doesn’t make a lot of sense to me since I’ve ran Manjaro with more recent kernels and everything worked fine. If anyone has any thoughts let me know and I’ll fiddle around with things and see what happens and comment back.

Update: The keyboard and everything else works fine. One difference I have noticed is everything is noticeably faster. I’m not talking speed of light but there isn’t a hesitation with things opening like there was before.

Keep in mind the change worked for MY box. Your mileage may vary if you elect to change kernels.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.
P.P.S. 5.4 is the most robust of the 5.x LTS kernels as it has been around for a long time whereas 5.10 is the newest one, so I’m not surprised 5.4 works, depending on the age of your Alienware… :wink:
P.P.P.S. Thanks for sharing your solution and welcome on board!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.