Keyboard layout doesn't persist across logins

Good day everyone.

First of all, I wouldn’t have asked if I had a clue but this issue is really weird. It’s quite simple but anything I tried and I could think of doesn’t help.
Thing is my second keyboard layout (Russian) in Plasma is always deleted on every log in to Plasma Wayland session. If logging to X session, it almost always is available, but in Wayland it is gone every time. It makes English the only layout and list of layouts in System Settings is always empty when I navigate there. Desktop widget gets “empty”, too.

I suspect a race condition when systemd starts Plasma services, but where to look for I wonder?

Did you have this issue before the last update of KDE plasma or something?

I have no issue (I tried to add any second different keyboard layout, Russian too) on KDE Wayland (Close to the default KDE theme).

Is this a general problem or maybe related to (old) config: can you reproduce it with a fresh user?

Sorry folks, I should have added more details but it was a late night when I wrote the first post.
OK here we go:

  1. New user’s account is also affected. I tried to remove a test user acc entirely with its home folder, create it from scratch - to no avail.
  2. This has already been a problem for quite a long period, like 4 or 6 months.
  3. I have systemdBoot set to true in ~/.config/startkderc in my main user account settings. As far as I know, it is a default setting on Plasma these days, so new accounts shouldn’t be explicitly configured this way.

Eureka, I figured it out. The culprit is fcitx5 or some of its settings or dependencies. I need it to input Japanese, and this makes me choose which option to sacrifice - my native language or Japanese. Well I can input Russian via fcitx5, too… However it’s not that convenient as a regular keyboard layout. Damn, Wayland is way behind X in terms of daily routine tasks for common users. Step left, step right - and you’re a clueless noob screaming for help.

Try to switch fcitx5 to fcitx4.
I remember fcitx5 has some problems for other apps. I switched it to fcitx4 to solve the problems.

Yeah, with fcitx4 this issue is not present.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.