Keyboard layout can not be selected

Hi I want to use the EurKey keyboard layout.
According to the information on its webpage it is bundled in the file xkeyboard-config.
The layout can be manually selected by using:

% setxkbmap eu

When I have selected the keyboard layout I can see the settings as follows:

% setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev…
Trying to load rules file /usr/share/X11/xkb/rules/evdev…
Applied rules from evdev:
rules: evdev
model: pc105
layout: us
options: terminate:ctrl_alt_bksp
Trying to build keymap using the following components:
keycodes: evdev+aliases(qwerty)
types: complete
compat: complete
symbols: pc+us+inet(evdev)+terminate(ctrl_alt_bksp)
geometry: pc(pc105)
xkb_keymap {
xkb_keycodes { include “evdev+aliases(qwerty)” };
xkb_types { include “complete” };
xkb_compat { include “complete” };
xkb_symbols { include “pc+us+inet(evdev)+terminate(ctrl_alt_bksp)” };
xkb_geometry { include “pc(pc105)” };

But in the GUI settings I can not select it so it is not persistent.
I had the same problems under ubuntu but the webpage supplies a .deb file that can be installed. So I installed it and then the setting showed up under UK keyboard settings.
I think this must be a bug that is persistent for many distributions and has not been dealt with. So now I wonder if there is a workaround to make the setting persistent. It would be nice if I could select it from the gui settings if possible. Also I wonder where I can make a bug report about the problem?

:+1: Welcome to Manjaro! :+1:

Please read this:

Especially the What’s this Upstream / Downstream business? and then file a bug upstream


  • Use the :us: International keyboard while the bug gets addressed:
    US International keyboard
    that one contains 99% of what you’re trying to do with the :eu: keyboard and it has been a standard for at least the last 25 years…


Now I feel dumb.
I had this problem in ubuntu gnome and when I did not find the EurKey I at first I thought the problem was the same. but it is not. It is there and selectable.
Anyway a lot of good information in the post you linked to. And good infromation on the EU standard keyboard layout I did not know there were an other that used US keyboard layout with AltGr to get the special keys. Perhaps I should switch since I like to be able to use a keyboard layout that is available on a lot of different machines.

Well thanks for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.