keyboard backlight not working

I have a Sony Vaio laptop and I cannot work out how to get the keyboard backlight to work. I have tried many of the suggestions that I found after doing a Google search, but none have worked so far.

/sys/class/input/event1/device/device/physical_node/subsystem/drivers/sony-laptop/sony-laptop/kbd_backlight is set to 1 and kbd_backlight_timeout is set to -1 (I have tried different values, but they all appear to get ignored)

I have also tried: sudo echo "options sony-laptop kbd_backlight=1" > /etc/modprobe.d/sony-laptop.conf but that didn't work either.

My machine's stats are as follows:

System:
  Host: corsair Kernel: 5.3.6-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Sony product: VPCSB27GG v: C609BC4Z 
  serial: <root required> Chassis: type: 10 serial: <root required> 
  Mobo: Sony model: VAIO serial: <root required> BIOS: INSYDE v: R1031H4 
  date: 04/25/2011 
Battery:
  ID-1: BAT1 charge: 44.9 Wh condition: 44.9/52.2 Wh (86%) volts: 12.4/11.1 
  model: Sony Corporation type: Li-ion serial: N/A status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19960 
  Speed: 798 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 799 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Sony driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126 
  Device-2: AMD Seymour [Radeon HD 6400M/7400M Series] vendor: Sony 
  driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6760 
  Display: x11 server: X.Org 1.20.5 driver: ati,intel,radeon 
  unloaded: modesetting alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.2.1 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Sony driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Sound Server: ALSA v: k5.3.6-1-MANJARO 
Network:
  Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi 
  v: kernel port: 7000 bus ID: 02:00.0 chip ID: 8086:0083 
  IF: wlp2s0 state: up mac: 8c:a9:82:6a:0f:2e 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Sony driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: f0:bf:97:63:6d:58 
Drives:
  Local Storage: total: 596.17 GiB used: 247.96 GiB (41.6%) 
  ID-1: /dev/sda vendor: Toshiba model: MK6459GSXP size: 596.17 GiB 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: 41TEB02NB rev: 1H scheme: MBR 
Partition:
  ID-1: / size: 584.83 GiB used: 247.96 GiB (42.4%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 1.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: radeon temp: 52 C 
  Fan Speeds (RPM): N/A 
Repos:
  Active pacman repo servers in: /etc/pacman.d/mirrorlist 
  1: http://mirror.is.co.za/mirrors/manjaro.org/stable/$repo/$arch
Info:
  Processes: 182 Uptime: 17m Memory: 7.69 GiB used: 1.91 GiB (24.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.36 

running sudo dmesg | grep backlight returns the following:

[   11.628775] sony_laptop: handle 0x014b: keyboard backlight setup already done for 0x0143
[   11.628777] sony_laptop: couldn't set up keyboard backlight function (-16)
[   16.136927] audit: type=1130 audit(1571124388.474:38): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:intel_backlight comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.178528] audit: type=1130 audit(1571124388.517:39): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:acpi_video1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.223194] audit: type=1130 audit(1571124388.561:40): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:acpi_video0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

Any help would be appreciated!
Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by