Keyboard and touchpad don't work on Asus laptop

We’re talking linux - anything is possible :relaxed:
You could also try to find an iso that is not too old that comes with < linux58 and than do the update, but this is a rolling distro and you might encounter dependency issues.

1 Like

Please run

sudo modprobe -r asus_nb_wmi
sudo modprobe -r asus_wireless
sudo modprobe -r asus_wmi

and the continue if none of them printed any errors.

2 Likes

So I just updated the kernel to 5.8.15 and disabled the workaround. Can confirm that it’s patched :+1:

@Sepp You could wait for the next iso to be released, but I don’t know how many weeks that will take…

1 Like

Glad to know im not the only one experiencing this issue. Im on a Razer Blade and the same happens. Ive used all three Manjaro environments and it boots in just fine but everything stops working as soon as the welcome screen comes in. Keyboard, touchpad, as well as my razer gaming mouse and keyboard which are both external. The only thing i can do is hard restart. Guess i will just wait/ install another distro :frowning:

1 Like

Keyboard lost after running the first line. I tried running the second line first and it worked with no problems. If run the third line first, it would give the “module in use” error.
Running the first line disables my keyboard.

Different plan, then. After you login, open /usr/share/libinput/50-system-asus.quirks in a text editor (e.g. nano) (with sudo), and add the following to the end:

[Asus WMI hotkeys]
MatchName=*Asus WMI hotkeys*
ModelTabletModeSwitchUnreliable=1

then save it. Then run startx -- -keeptty.

1 Like

After running startx -- -keeptty, it gives a long output with initial errors after a short moment of black screen.

xauth: file /home/manjaro/.Xauthority does not exist
xauth: file /home/manjaro/.Xauthority does not exist

X.Org X Server 1.20.9
...

Edit: after running that again, I found this time it gives this error:

...
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
...
xinit: connection to X server lost
...

Try the following:

rm -f ~/.Xauthority
touch ~/.Xauthority

and then try again.

1 Like

Still it gives the second error I added in my last post.

That error shouldn’t really be a problem. Please run sudo systemctl isolate graphical.

1 Like

Thanks! It finally worked! Thumbs up for your expertise. :+1:

Please note that before you reboot, you should check if the /usr/share/libinput/50-system-asus.quirks file on the ssd/hdd contains those three lines. If you reboot without those three lines, you probably won’t even be able to log in. And you have to start the system in runlevel 3, edit the file, the start the graphical target again.

1 Like

With that fix, now both touchpad and keyboard work :slight_smile:.
I suppose you mean checking that file after the installation and before shutting down or rebooting.

Correct.

1 Like

The new isos are up already :+1:

1 Like