Key repeat getting reset

I have the key repeat rate set with dconf

dconf write /org/cinnamon/settings-daemon/peripherals/keyboard/delay "uint32 150"
dconf write /org/cinnamon/settings-daemon/peripherals/keyboard/repeat-interval "uint32 10"

But after the computer stays on for a while the setting changes to the default.

Writing the above commands again doesn’t fix it so it must be changed in some other way than with dconf. All other dconf configurations I have keeps working normally.

I’ve had this same problem for a few months and I haven’t been able to figure out what is changing the settings. Is there any way for me to know if there is a program changing the settings?

You can try checking the system logs to see if there are any messages related to changes in the keyboard settings. You can use the command “journalctl -f” to view the logs in real-time and check if there are any messages related to changes in the keyboard settings.

Another option is to use the “strace” command to trace the system calls made by a specific program. For example, you can use “strace -p PID” (where PID is the process ID of the program) to trace the system calls made by that program. This may help you identify if a specific program is making changes to the keyboard settings.

You can also try disabling any keyboard-related services or daemons that may be running on your system, such as gnome-settings-daemon, to see if that stops the settings from changing.

Lastly, you can try searching for any scripts or configuration files that may be running on your system that may be modifying the keyboard settings. These could be located in the /etc/ or /usr/local/etc/ directories.

— ChatGPT