Kerning Broken After Installing and Removing KDE

After using GNOME, I was on Sway for a while, but the number of small broken things eventually got to me and I wanted to try out KDE with KWinFT. I installed it, tried it out on a new user account (never logged in to KDE on my main one), didn’t like it, and removed it (including orphans). I moved back to GNOME, but now the kerning (interletter spacing) is broken in GTK applications. The recent update to GNOME 41 and Linux 5.15 had no effect. Applications like Firefox are rendering text correctly, however, as are Qt ones.
I run mainline kernel, default graphics drivers, and only Wayland sessions.

I looked through the list of removed orphans, thinking maybe it removed something important, but the only package related to font rendering I saw removed was xorg-font-util and reinstalling it had no effect. I also tried reinstalling pango and cairo with no effect. I’ve been searching but haven’t been able to figure out where kerning settings are stored. I’ve also tried switching between fonts for UI, and none of them have working kerning.

Can someone point me to where I might be able to find relevant settings?

Bumping—any more information I can provide? I’m really struggling to find info on how kerning is handled and how it could possibly be borked for all fonts. It seems to be entirely internal to Pango, so how I can change those settings (if there are any?)

Can you post inxi -Fza ?


System:    Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64 root=UUID=3b8a551e-d7c7-45d0-b637-be4e06c5bcac ro apparmor=1
           security=apparmor resume=UUID=bd9cee86-23af-4ba0-a4a2-57382d64232e udev.log_priority=3
           Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0 Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF serial: <superuser required>
           Mobo: Gigabyte model: X570 AORUS ELITE serial: <superuser required> UEFI: American Megatrends LLC. v: F34
           date: 06/10/2021
CPU:       Info: 12-Core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25) model-id: 21 (33)
           stepping: 0 microcode: A201009 cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 177669
           Speed: 3871 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 3871 2: 3009 3: 2201 4: 2200 5: 3752
           6: 3330 7: 2968 8: 2976 9: 2944 10: 3209 11: 2332 12: 2276 13: 2997 14: 2210 15: 2209 16: 2207 17: 2211 18: 3155
           19: 2919 20: 2972 21: 2372 22: 2213 23: 2389 24: 3702
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Gigabyte
           driver: amdgpu v: kernel bus-ID: 08:00.0 chip-ID: 1002:67df class-ID: 0300
           Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-3.4.1:6 chip-ID: 046d:0825
           class-ID: 0102 serial: <filter>
           Display: wayland server: X.Org compositor: gnome-shell driver: loaded: amdgpu,ati unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") s-diag: 777mm (30.6")
           Monitor-1: XWAYLAND0 res: 2560x1440 hz: 60 dpi: 123 size: 530x300mm (20.9x11.8") diag: 609mm (24")
           OpenGL: renderer: AMD Radeon RX 570 Series (POLARIS10 DRM 3.42.0 5.15.2-2-MANJARO LLVM 13.0.0) v: 4.6 Mesa 21.2.5
           direct render: Yes
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Gigabyte driver: snd_hda_intel
           v: kernel bus-ID: 08:00.1 chip-ID: 1002:aaf0 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
           bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
           Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-3.4.1:6 chip-ID: 046d:0825
           class-ID: 0102 serial: <filter>
           Device-4: Thesycon System & Consulting E30 type: USB driver: snd-usb-audio bus-ID: 5-2:2 chip-ID: 152a:8750
           class-ID: fe01
           Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel port: f000 bus-ID: 04:00.0
           chip-ID: 8086:1539 class-ID: 0200
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: docker0 state: down mac: <filter>
Bluetooth: Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-3.4.4:8 chip-ID: 0a5c:21e8
           class-ID: fe01 serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.69 TiB used: 1.47 TiB (54.4%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket 4.0 1TB size: 931.51 GiB block-size:
           physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: RKT401.3 temp: 41.9 C
           scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37960G size: 894.25 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: K1C3 scheme: GPT
           ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WDS500G2B0B-00YS70 size: 931.5 GiB
           block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: GPT
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 874.29 GiB size: 860.07 GiB (98.37%) used: 214.34 GiB (24.9%) fs: ext4 dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 300 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 56.93 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:   System Temperatures: cpu: 34.0 C mobo: 30.0 C gpu: amdgpu temp: 51.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:      Processes: 513 Uptime: 21h 1m wakeups: 7 Memory: 62.81 GiB used: 9.4 GiB (15.0%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 2644 pacman: 2625 lib: 527 flatpak: 19 Shell: Zsh
           v: 5.8 running-in: guake inxi: 3.3.09

Seems to have fixed itself after a minor GNOME update. Weird. Just wanted to document in case this happens to anyone else.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.