Kernel Updates [Solved]

kernel

#1

This is not a crucial issue, but I noticed that there is a Kernel update to 4.15 and an experimental update to 4.16 in System Settings.

Is there a reason there has been no updates to let’s say 4.15.4? I didn’t see anything when I searched the forum.

Thanks


#2

I’d rather say there’s no reason all kernels shall have an update at the same time, every time.


#3

Does a particular version exist? If it does, there will be an update when an update becomes available as part of the normal update flow from unstable->testing->stable.

As it is, I’m running 4.15.6 on the unstable branch. Latest on the stable branch is 4.15.5 ([Stable Update] 2018-02-25 - Kernels, Plasma, Mesa, Systemd, QT5, Browsers). If you haven’t had a recent update you should refresh your mirror list and check for updates again,

sudo pacman-mirrors -f 3
sudo pacman -Syyu

#4

You can see which kernels are updated in Phil’s update announcement posts.


#5

Also by searching the forum… https://forum.manjaro.org/search?q=4.15.4 :roll_eyes:


#6

Did what you suggested, but on the Stable branch 4.15.5 does not show up in
System Settings.

I ran the following commands and rebooted:

sudo pacman-mirrors -f 3
sudo pacman -Syyu


#7

If this is the case your mirror was out-of-date and the commands you followed should have fixed that.

4.15.5 is definitely in the stable branch, check e.g. https://mirror.netzspielplatz.de/manjaro/packages/stable/core/x86_64/ :


#8

Hmmm, if the commands didn’t fix the issue, is there anything else I can do?

Thanks for all the replies.


#9

If the commands from the post above do not update your mirrors and synchronise your packages with the stable repo then there’s something else going on.

You could try setting your mirror explicitly to one that’s known to be up-to-date, and detailing any steps, output, and relevant file contents, to see if there are any errors.

/etc/pacman-mirrors.conf
/etc/pacman.d/mirrorlist

pacman -Ss linux415$


#10

Not sure how to insert a specific mirror, so I inserted United_States, saved the file.

Not sure what I’m doing wrong. So I decided to do a pastebin:

https://pastebin.com/0P3JGgRd

Thanks for any help.


#11

OK, that output shows an updated mirror list and no updates from those mirrors. Given one of them is @fhdk’s mirror I know that it’s up-to-date.

So the next question is, which version of the linux415 package is available to you?

pacman -Ss linux415$

#12

Wow, pacman -Ss linux415$ tells me that the latest version is available, but it is not showing up in System Settings. I only get Linux 415 & Linux 416 (Experimental). I have no clue how to install the latest stable Kernel via the command line.

One other other question: If I am in NY why am I getting an updated mirror list from Europe and Russia?

Thanks


#13

I don’t understand, you they both… that is availabe and not available… :thinking:


#14

Can you provide some command output and screenshots please? What you’re saying is happening doesn’t make sense if it is happening in the way you’re saying it is, and if it is happening then there’s a major bug somewhere.

Use mhwd-kernel.

-f 3 picks the three most recently-updated mirrors, not the ones closest you you. For more information about pacman-mirrors, read

man pacman-mirrors

#15

Sorry I was not clear. Via command line with the command you gave me, the the latest Kernel 415.5.1.

System Setting - Kernel only shows Kernel 415, nothing else in the 415 series of Kernel.


#16

show a screenshot
there is only 1 version of kernel for each series…
if system settings show you kernel 4.15 it will install the latest version of the kernel for the serie 4.15

in my case 4.15.7 as I’m on unstable branch

and you will receive update for each kernel series you installed during normal updates.


#17

You should see something like


#18

There you go.

Thanks


#19

all is right… as kernel 4.15.5 is the current version on stable branch.


#20

OK now it is there. A few minutes ago it wasn’t…

One last question, there was a time that I would get a notification that a new Kernel was available, but not anymore. Is that by design or do I need to change a System Setting to receive said notification?

Thanks for all your help.