Kernel panic or freeze sometimes

Sincerly I don’t know why this happen, but maybe it’s due to kernel incompatibility with your hardware.
Ever tried switching to a newer kernel? Maybe with 4.5 it will not happen again.

Regards

No, and the hardware is quite new. I ugrade my cpu/mobo/ram about a month ago and I replaced to mobo again before 10 days. This problem started after the recent kernel update(4.4.9.1), with the previous there was no problem. I never had such problem before on manjaro or ubuntu 16.04 which I also have. I reinstall the kernel before some hours and I’ll see if it happens again. Then I will try another kernel.

My hardware is a few years old and I can’t use 4.4 due to kernel panic.

I get the ‘Kernel Panic’ whenever I happen to install a linux distro that supercedes the manjaro bootoader*. At the present I ahve five distro installed with the last one being Manajro KDE 16.06.1 with the 4.44 LTS Kernel installed. When I have experience the Kirnel Panic befroe I ahve had to reinstall Manjaro.

  • I believe it is the bootloader that is in some way at fault because I do not have this issue with the other distros I’ve instaled.

My PC (HP Pavilion Slimline 400-334 PC) is fairly new and I have not had any problem moving up to a newer kernel such as 4.6 and I could do so again.

When I have experience the Kirnel Panic befroe I ahve had to reinstall Manjaro.

It is not needed. Just chroot to Manjaro and sudo update-grub should fix it.

How do I ‘chroot’ to Manjaro’, when I am in that situation? Last time it occurred and I was staring at the ‘kernel panic’ screen, I tried; ‘Ctrl+Alt+F1’ and ‘Ctrl+Alt+F2’ and nothing happened. What do I need to do and where do I need to do it from?

Boot from Manjaro installation media, connect to network, open terminal and run sudo pacman -S mhwd-chroot , then mhwd-chroot. It will autodetect your installed Manjaro system and start shell for you as root inside it. Then do sudo update-grub. Then exit. Reboot from hdd.

1 Like

I followed your directions and came up with:

[manjaro@manjaro~]$ mhwd-chroot

bash: mhwd-chroot: command not found. I then tried:

[manjaro@manjaro~]$ sudo mhwd-chroot

bash: mhwd-chroot: command not found.

It did not detect my installed manjaro. I came up with the same non-result with:

[manjaro@manjaro~]$ su

[root@manjaro manjaro~]# mhwd-chroot

bash: mhwd-chroot: command not found

bummer…

Did you install mhwd-chroot?

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader
https://old.forum.manjaro.org/index.php?topic=21472.0

1 Like

Install it. I edited my post to show how to do that.

Following the steps you provided I installed ‘mhwd-chroot’. However, I ran into a snag:

[manjaro@manjaro ~] $ mhwd-chroot
kdesu konsole --separate -e mhwd-chroot-shell

A small window opens:

            'Sorry kde su

Cannot execute command’’ “–separate -e mhwd-chroot-shell”

I tried another manjaro installation disk, a ‘Manjaro LXQT 16.02’, with “mhwd-chroot” already installed, and this is what happened with that one:

“[manjaro@manjao ~ ] $ mhwd-chroot
gksu term -e mhwd-chroot-shell”

A new terminal opens:

“List of found systems
0) /dev/sda3

  1. /dev/sda4
  2. /dev/sda5
  3. /dev/sda6
  4. /dev/sda7 (Manjaro)
  5. /dev/sda8

Please enter your choice (0-5) 4
/dev/sda7
swapon UUID=12009772-f4ad-4f75-a2fc-be15018acc23
[root@manjaro / ] # update-grub
Generating grub configuration file
Found background: /usr/share/grub/background.png
Found Intel Microcode Image
Found Linux image: /boot/vmlinuz-4.4-x86_64
Found initrd image: /boot/initramfs-4.4-86_64
Found initrd fallback image: /boot/initramfs-4.4-x86_64-fallback.img

WARNING: Not using lvmetad with older version”

Nothing happened, it remained that way for several minutes until I manually closed it down and rebooted into one of the other distros to write this.

Seems it can’t handle your LVM configuration. Sorry, I have no experience with LVM.

you should leave it to finish. I had similar problem with update-grub which caused by an extended partition. Grub update needed about 10 minutes or more to finish because of this.

There is another way to boot Manjaro after grub update from other distro. No live media or chroot is needed.
Try to use this


If you can boot to Manjaro, update grub from it.
To avoid this problem you should manually create a grub entry in other distro to boot grub. I think the difference is that Manjaro requires intel microcode to boot, so create or edit /etc/grub.d/40_custom file and put there grub entry created by Manjaro’s grub with microcode included.

I copied the info from the link you provided and am about to try it but am curious as to whether at the ‘boot into manjaro’ my entry should be “sudo grub-install /dev/sda1”, seeing as how that is where the “Fat32 /boot/efi” is situated or enter as “sudo grub-install /dev/sda”?

I could try it ‘update-grub’ again and let it run and run and run and… If it works great and if not I will have the information provided by kainonergon, as a fallback.

Using the Manjaro LXQT installation disc I proceeded with the “mhwd-chroot” ‘update-grub’ and see it to its conclusion, which was not as long as I had supposed. Unfortunately, when I rebooted it was to a Grub screen with ‘openSUSE’ at the top and Manjaro was still in ‘kernel panic’. The fault lay in my trying to use a ‘manjaro lxqt’ to fix a manjaro kde. It had not occurred to me at the time that thenre might be a problem.

Now to consider my other option

With UEFI see in that tutorial:

And all the following applies only to bios-legacy/msdos.
If system is uefi/gpt, just go to uefi bios to reset Manjaro as default boot and then “update-grub” if necessary

So don’t do grub-install. Just select Manjaro from firmware boot settings (from BIOS setup).

When I had Manjaro and OpenSUSE (and Win8) multiboot with UEFI, I used theese articles



to learn how to set up grub to chainload from Manjaro grub to OpenSUSE grub and vice versa.
So I had an entry in Manjaro grub menu to select OpenSUSE and it loaded its own grub menu. The same from OpenSUSE to go to Manjaro grub menu. Very convenient.

I found the ‘firmware boot settings’ on my HP within the Hewlett-Packard Set Up Utility’s Storage marked as BootLoader. Listed in it was all the distros installed past and present including ‘Manjaro’. I had all but resigned myself to reinstall Manjaro when I saw the list with Manjaro on it and Duh. I was looking at HP’s firmware boot settings. I selected ‘manjaro’ moved it to the top of the list, using the up arrow, then hit F10 to accept my choice. Next, I used the left arrow to move to File, then using the down arrow moved down to “Accept change and Exit”, where I clicked it.

My Manjaro KDE 16,06-1 came up, with no kernel panic, and I was able to login. I know that should I add a new distro, I will just do what I did, thanks to your hint, and I’ll be okay.

I did do:

“sudo update-grub” more or less as a precaution.

1 Like

Thanks for the links, I’ve raed both articles. Some of it went over my head but I’ve copied them for future reference.

Forum kindly sponsored by Bytemark