Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

#16

One significant but resolvable problem! I got kernel panic on first boot of the installed system because of Plymouth-Grub issue. Like here: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Then I chrooted (FYI for btrfs subvolume install the first mount command is mount -o subvol=@ -t btrfs /dev/sda1 /mnt) and took a look at mkinitcpio.conf. There only the plymouth hook was there, so I changed it to HOOKS="base udev block filesystems plymouth". Then ran mkinitcpio -P, edited /etc/default/grub to have not only quiet but quiet splash, ran update-grub and was able to boot the installed system having your stylish plymouth.
Please, make these settings default!:slight_smile:
PS: I installed with the CLI installer.

2 Likes
#17

Thank you, @eugen-b ! This is strange.
When you look at the mkinitcpio.conf in manjaro-tools-iso-profiles you see that everything is there. So I wonder what happened on the way to your install.
Either this is a bug in the tools, or it has to do with btrfs… We’ll have to investigate this!

#18

Hello, Bernhard!
I finally got the chance to check that the same issue (kernel panic after install) is occuring on my KDE install from the 02.08.2016


due to exactly the same reason: /etc/mkinitcpio.conf contains only HOOKS=" plymouth" and /etc/default/grub does not contain splash.
I will see if I can repair it exactly like my Deepin install. (Which is running ok on my little “Frankenstein” computer.)

#19

But do you think this is specific to a desktop environment? Will it not just happen with any ISO using plymouth? How about xfce with the same kernel version?

#20

Good point! It is not a Deepin edition problem as it happened with KDE as well. I’m moving my posts and your replies to a general hardware topic. (The whole report is meant for other users anyway who would encounter a similar issue.)
Update: Moved the posts to this thread here.

#21

Maybe it’s the installer forgot to use that mkinitcpio.conf? What did you install with, Calamares or Thus?

#22

In my case it was the CLI installer and it must have created a wrong mkinitcpio.conf

#23

I tried Calamares and could not reproduce the issue - mkinitcpio.conf is ok. I tried Xfce-dev 16.10 ISO.
So it seem to be an issue with the discontinued CLI installer.

#24

Yeah, it seems like got something to do with the huge commit on June 06. But anyway, Calamares is going to take over anything soon. So maybe just ask the new users to use Calamares instead? :slight_smile:

#25

I’m officially giving up Manjaro because of this issue. After many hours failing to install Manjaro because of an unpack problem with kde-image.sqfs I finally got Manjaro installed. When I tried to boot it I got this kernel issue. I tried to do the following but didn’t work:

sudo fdisk -l
sudo mount /dev/sdax /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

mkinitcpio -g /boot/initramfsi486.img 4.4.19-1-MANJARO (don’t consider the name of the .img file, it’s just an example).

I had to get back to linux Mint. Mint isn’t that fast as Majaro is, but it never crashs.

Updated Kernel on Linux Mint, now cannot boot Manjaro
#26

You forgot to correct etc/mkinitcpio.conf before running mkinitcpio -P :weary:

#28

That’s because I don’t have that knowledge. I did everything I found on many Manjaro and Arch forums, but nothing could fix it. Also, I couldn’t find any offical guide from Manjaro’s web site on how to solve this.

#29

I wrote in this topic what needs to be added to /etc/mkinitcpio.conf
HOOKS="base udev block filesystems plymouth"
An official guide for an issue which happens to only few users is too much.
But the forum is always here to ask. :slight_smile:

1 Like
#30

Alright, I’ll try that.

#31

Man, Thank you. Im glad to inform that I followed your tips and that did the trick. Im writing this from my new Manjaro system, but now I have another disappointment. Manjaro only recognizes 2.9 out of 4G Ram installed. It should recognizes 3.8 GB. I`ll try to find the solution for this new issue in the right topics. Thank you again.

1 Like
#32

Please don’t forget to put the topic as solved. There’s a button at the bottom of each post to mark a post as solution.
Mark the post that solved your problem. :slight_smile:

#33

OP solved it, I marked his post.

1 Like
split this topic #34

A post was split to a new topic: Updated Kernel on Linux Mint, now cannot boot Manjaro

split this topic #35

2 posts were merged into an existing topic: Updated Kernel on Linux Mint, now cannot boot Manjaro

closed #36