Kernel panic - not syncing of Manjaro, after installation of another distro in unallocated space

grub
kernelpanic

#1

Hello everyone,

I’ve installed another distro in some free GB of unallocated space. Grub seems fine and windows10 is ok, problem is when I choose Manjaro,

as you can see in the picture above the first line begins with “Kernel panic - not syncing; VFS: Unable to mount root gs on unknown-block(0,0)” …

Manjaro is installed in /dev/sda4. Does anyone know how to fix this problem? Thanks anyways.

Additional photos:


#2

Can you boot into ArcoLinux and post the output of:

lsblk -f

That will let us see all the file systems of the various partitions, and the partitions used by ArcoLinux.


#3

reboot with USB install Manjaro
open a terminal

manjaro-chroot -a
update-grub
exit ( for leaving chroot)

then reboot

grub manjaro required path for img Kernel AND microcode ,
that others distros do not support


Problems with GRUB Manjaro and login in Fedora
#4

Please check if you have the right kernel image listed in your Grub boot entry and not only intel-ucode.img. I recommend to remove the package intel-ucode if you’re not using the Manjaro Grub-Bootloader but Grub from another distro. Only with Grub v2.03 or higher multiple initrd images are supported.


#5

Thanks to all! I’ve tried all solutions and found that I’ve only intelucode.img so I’ve deleted it and added at initrd /boot/initramfs-4.14-x86_64.img and works fine when I boot with F10/CTRL X I can use Manjaro.

Problem is when I shutdown or reboot, there is again kernel panic for the simple reason that grub boot menuentry isn’t edited anymore. How to save it with the edits? Tried with “e” or “TAB” but it doesn’t work


#6

Use this.
note: step 1 - When ArcoLinux grub menu appears, not Ubuntu (in the link)


#7

It worked thanks :slight_smile: now there is GRUB 2.03 of Manjaro and /boot/initramfs-4.14-x86_64.img is in the right place


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.