Kernel Panic / Manjaro switch from /dev/sd4 to /dev/sd7

Actually nothing has changed you need to use UUID as the partition identifier not sda sdb that was for ide drives and sata does not recognise them so they change on boot up, The chances are when you installed it was UUID check your fstab its easy to change to UUID anyway read the arch wiki

Ok, thanks . Let me give it a try…

Hey, I think I’ve found where the problem was ! But now I’m still facing the KERNEL PANIC issue !
I found on a forum that to fix it I had to make sure a line called “/boot/intel-ucode.img” was written right after " initrd " inside the grub.cfg ! I checked and found out that all was in order but still I have the KERNEL PANIC !

I just want to add here that I’m using a Debian Based GRUB !

Thanks

Best way to boot Manjaro is with Manjaro grub, separate intel microcode image causes kernel panic on non Arch grubs. Manjaro grub also works well booting other distros.

If you still want to use Debian grub then do a forum search for booting Manjaro in other grubs, @gohlip has helped others manually create the correct Manjaro grub entry.

Thanks for your support !

Well I have 2 Linux Distros on my laptop ,which are Ubuntu and Manjaro ; But since I had the issue with my Manjaro , I by mistake made an " sudo update-grub on my Ubuntu and my laptop will use the Debian based GRUB !

So is there a way to change the Debian based GRUB to a Manjaro GRUB for my boot ?

May be using a Live CD of Manjaro ?

Thanks

This is to get back your Manjaro grub as default.
And this is to prevent Manjaro grub from being overridden in the future.

Good luck.

Ok THANKS , that helped me a lot !

Now I’m to my Manjaro GRUB

But now when I select my Kernel at boot , I have a “Failed to start load Kernel Modules”

Any fix for that ? I’ve tried all of the Kernels on the list but it still does that !

Manually change to root=/dev/sda7 in the linux line and see if that boots.
To change, at menu entry, press ‘e’ at Manjaro entry (pick a kernel), and arrow down to linux line.
Where line is

linux	/boot/vmlinuz-xxx.xxx root=UUID=xxxxxxxxxxxxxxxx rw  quiet resume=UUID=yyyyyyyyy

Change to

linux	/boot/vmlinuz-xxx-xxx root=/dev/sda7 rw  

Yes, remove also resume=UUID=yyyyyyyyyyyyy to be certain.

First check that /dev/sda7 is really where the Manjaro root (and /boot) is by

grub> ls (hd0,7)/boot/

When booted up correct /etc/fstab to the correct partitions and also /etc/default/grub
Then do ‘sudo update-grub’ to complete.

ps: if you have installed Debian after installing Manjaro, it is likely the swap UUID has also changed.
Check that with ‘sudo blkid’ and make changes accordingly.

Ok, but which Linux line are tou talking about ?

I mean where should I change what you told me ?

Your first screen in post 8.
Press ‘e’ at that screen.
Then the entry will appear.
Arrow down to linux line…

[edit]
Arrow right past things to remove…
Backspace to remove them
’Ctl’+‘x’ or F10 to boot

Do not press ‘esc’, otherwise you will need to redo as ‘esc’ will revert to original.

Great thanks ,let me give it a try !

Well I’ve change it but I still have the “Failed to start load kernel modules

Now I’m wondering what the problem could be !

It is not clear if you finally entered manjaro/LightDM.
Anyway, from similar posts you may have a conflict with virtualbox packages versions, or some other module loading in kernel during boot.
Do a search with your error message in the forum to have an idea.

Boot up a livecd and use its file manager to look into Manjaro partition (sda7?) and let us know its
o /etc/fstab
o /etc/default/grub
o One entry of Manjaro at /boot/grub/grub.cfg

Then at livecd terminal, provide output of
o sudo blkid
o sudo parted -l (small 'L)

It may just be simpler if you want to reinstall, I understand; but we’ll try to help you through all this.
Good luck.

OK , let me do that and get back to you !

Thank you for your time !

Hey ,

Here you got the fstab output :


Then you got the /etc/default/grub :


I did not get when you said "One entry of /boot/grub/grub.cfg " ,so here is all of it :


Here is the output of “sudo blkid” :

pastebin.com/embed_js/nqDf0dLF


Then the output of “sudo parted -l” :

P.S : I do not know if I am allowed to use pastbin on the Forum , but yeah that it is !

Right, everything seems to be in order (correct).
Just that when you installed Ubuntu, it created a new primary partition for it and reordered it as sda4 and reordered your Manjaro logical partition as sda7. (That’s why it is best to have partitions ready before installation)

Now let’s try to see if your kernels/initramfs are still valid and boot issues are not due to bootloader problem.
BTW, your screen shot in your post 8 shows an old grub version (1.xx). Hope you’ve kept your Manjaro up to date.
So let’s try to boot Manjaro from Ubuntu’s grub. To do this, at grub menu, press ‘c’ and we get to grub prompt.

grub> set root=(hd0,4)
grub> multiboot /boot/grub/i386-pc/core.img
grub> boot

This will give us the Ubuntu grub menu

At Manjaro menuentry, press ‘e’.
Arrow down to the linux and initrd line, where the line shows somthing like

linux	/boot/vmlinuz-4.13-x86_64 root=UUID=6af0880c-dcb7-4d1b-b54c-e47d1b9e9d51 rw  quiet splash
initrd	/boot/intel-ucode.img

Change to

linux	/boot/vmlinuz-4.13-x86_64 root=UUID=6af0880c-dcb7-4d1b-b54c-e47d1b9e9d51 rw acpi_osi=Linux acpi_backlight=vendor  
initrd	/boot/initramfs-4.13-x86_64.img

notes :
use corresponding initramfs in initrd line as the kernel in linux line.
arrow right past things to remove, backspace to remove.
added “acpi_osi=Linux acpi_backlight=vendor” that your laptop requires, remove ‘quiet’ and ‘splash’ to be certain
careful not to remove ‘rw’; if ‘ro’ change to ‘rw’
initrd line change to just kernel
’ctl’ +‘x’ or F10 to boot.
Do not press ‘esc’, otherwise redo all.

If this boots, reinstall bootloader (update/upgrade first)
sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub

If this still does not boot, suggest you chroot into Manjaro and reinstall kernels (update/upgrade first) and reinstall bootloader (as above).

Good luck.

I have tried what you advised me , but I did not work ! So now I want to re-install the Kernels as you said; But it looks like I do not have internet acces in chroot !

You may try running nmtui in chroot and access the internet with it

I tried but I receive this error : Could not contact NetworkManager: Could not connect: No such file or directory

Forum kindly sponsored by Bytemark